PHP 7.4.x < 7.4.3 Multiple Vulnerabilities

2020-02-28T00:00:00
ID WEB_APPLICATION_SCANNING_98973
Type nessus
Reporter This script is Copyright (C) 2020-2021 and is owned by Tenable, Inc. or an Affiliate thereof.
Modified 2021-09-07T00:00:00

Description

According to its banner, the version of PHP running on the remote web server is prior to 7.2.28, 7.3.x prior to 7.3.15, or 7.4.x prior to 7.4.3. It is, therefore, affected by multiple vulnerabilities:

  • A heap buffer overflow exists in phar_extract_file. (CVE-2020-7061)

  • A null pointer dereference exists in PHP session upload progress. (CVE-2020-7062)

  • A file permissions bypass exists when files are added to tar with Phar::buildFromIterator. (CVE-2020-7063)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

                                        
                                            No source data