PHP 7.3.x < 7.3.5 Heap-based Buffer Overflow Vulnerability

2019-05-22T00:00:00
ID WEB_APPLICATION_SCANNING_98599
Type nessus
Reporter This script is Copyright (C) 2019-2021 and is owned by Tenable, Inc. or an Affiliate thereof.
Modified 2021-09-07T00:00:00

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.29, 7.2.x prior to 7.2.18 or 7.3.x prior to 7.3.5. It is, therefore, affected by a heap-based buffer over-read condition within _estrndup of the exif_process_IFD_TAG in the exif.c script. An unauthenticated, remote attacker can exploit this, to cause a denial of service condition or the execution of arbitrary code.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

                                        
                                            No source data