The version of Apache Tomcat installed on the remote host is 8.5.50 to 8.5.81, 9.0.30 to 9.0.64, 10.0.0-M1 to 10.0.22 or 10.1.0-M1 to 10.1.0-M16. It is, therefore, affected by a Cross-Site Scripting (XSS) vulnerability. The Form authentication example in the examples web application displayed user provided data without filtering, exposing a XSS vulnerability. Note that the scanner has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.
Security Bulletin: The CVE-2022-34305 vulnerability in Apache Tomcat affects App Connect Professional.
Security Bulletin: IBM Data Risk Manager is affected by multiple vulnerabilities including remote code execution in Apache Log4j 1.x
Cross-site Scripting (XSS)
Apache Tomcat < 10.0.23 Vulnerability
Apache Tomcat < 8.5.82 Vulnerability
Apache Tomcat < 10.1.0-M17 Vulnerability
Apache Tomcat < 9.0.65 Vulnerability
Cross-site Scripting in Apache Tomcat
Apache Tomcat CVE-2022-34305
Confluence Apache Tomcat CVE-2022-34305