logo
DATABASE RESOURCES PRICING ABOUT US

Squid < 4.9 Multiple Vulnerabilities

Description

According to its self-reported version number, the version of Squid installed on the remote host is prior to 4.9. It is, therefore, affected by multiple vulnerabilities: - A heap overflow and possible a remote code execution exist due to incorrect buffer management when processing URN. (CVE-2019-12526) - A security bypass exists due to improper input validation. An attacker can gain access to restricted HTTP servers. (CVE-2019-12523) - A buffer overflow exists due to incorrect input validation which can result in denial of service to all clients using the proxy. (CVE-2019-18676) - A traffic redirect exists due to incorrect message processing with append_domain settings. (CVE-2019-18677) - A HTTP request splitting exists due to incorrect message parsing. (CVE-2019-18678) - An information disclosure exists due to incorrect data management when processing HTTP Digest Authentication. (CVE-2019-18679) Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Related