Lucene search

K
nessusThis script is Copyright (C) 2021-2024 and is owned by Tenable, Inc. or an Affiliate thereof.WEB_APPLICATION_SCANNING_112690
HistoryFeb 10, 2021 - 12:00 a.m.

Squid < 4.12 Multiple Vulnerabilities

2021-02-1000:00:00
This script is Copyright (C) 2021-2024 and is owned by Tenable, Inc. or an Affiliate thereof.
www.tenable.com
16

According to its self-reported version number, the version of Squid installed on the remote host is 5.x < 5.0.3 or prior to 4.12. It is, therefore, affected by multiple vulnerabilities:

  • Due to an incorrect synchronization, Squid is vulnerable to a denial of service attack when processing objects in an SMP cache. (CVE-2020-14059)

  • Due to use of a potentially dangerous function Squid and the default certificate validation helper are vulnerable to a denial of service attack when processing TLS certificates. (CVE-2020-14058)

  • Due to incorrect input validation Squid is vulnerable to a request smuggling and poisoning attack against the HTTP cache. (CVE-2020-15049) Note that the scanner has not tested for these issues but has instead relied only on the application’s self-reported version number.

No source data
VendorProductVersionCPE
squid-cachesquid*cpe:2.3:a:squid-cache:squid:*:*:*:*:*:*:*:*