IBM WebSphere Portal Unspecified Reflected XSS (PI30620)

2015-04-17T00:00:00
ID WEBSPHERE_PORTAL_CVE-2014-8909.NASL
Type nessus
Reporter Tenable
Modified 2015-04-26T00:00:00

Description

The version of IBM WebSphere Portal installed on the remote host is affected by an unspecified cross-site scripting vulnerability due to improper validation of user-supplied input. A remote attacker can exploit this flaw using a specially crafted URL to execute arbitrary script code in a user's web browser within the security context of the hosting website. This allows an attacker to steal a user's cookie-based authentication credentials.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include("compat.inc");

if (description)
{
  script_id(82851);
  script_version("$Revision: 1.5 $");
  script_cvs_date("$Date: 2015/04/26 04:36:14 $");

  script_cve_id("CVE-2014-8909");
  script_bugtraq_id(73958);
  script_osvdb_id(117951);

  script_name(english:"IBM WebSphere Portal Unspecified Reflected XSS (PI30620)");
  script_summary(english:"Checks for installed patches.");

  script_set_attribute(attribute:"synopsis", value:
"The remote Windows host has web portal software installed that is
affected by a cross-site scripting vulnerability.");
  script_set_attribute(attribute:"description", value:
"The version of IBM WebSphere Portal installed on the remote host is
affected by an unspecified cross-site scripting vulnerability due to
improper validation of user-supplied input. A remote attacker can
exploit this flaw using a specially crafted URL to execute arbitrary
script code in a user's web browser within the security context of
the hosting website. This allows an attacker to steal a user's
cookie-based authentication credentials.");
  script_set_attribute(attribute:"see_also", value:"http://www-01.ibm.com/support/docview.wss?uid=swg21694738");
  script_set_attribute(attribute:"solution", value:
"Upgrade to IBM WebSphere Portal 6.1.0.6 CF27 / 6.1.5.3 CF27 /
7.0.0.2 CF29 / 8.0.0.1 CF15 or later. Alternatively, apply interim fix
PI30620.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N");
  script_set_cvss_temporal_vector("CVSS2#E:ND/RL:OF/RC:C");
  script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"true");

  script_set_attribute(attribute:"vuln_publication_date", value:"2015/02/02");
  script_set_attribute(attribute:"patch_publication_date", value:"2015/02/02");
  script_set_attribute(attribute:"plugin_publication_date", value:"2015/04/17");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:ibm:websphere_portal");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2015 Tenable Network Security, Inc.");

  script_dependencies("websphere_portal_installed.nbin");
  script_require_keys("installed_sw/IBM WebSphere Portal");

  exit(0);
}

include("websphere_portal_version.inc");

websphere_portal_check_version(
  ranges:make_list(
    "8.0.0.0, 8.0.0.1, CF15",
    "7.0.0.0, 7.0.0.2, CF29",
    "6.1.5.0, 6.1.5.3, CF27",
    "6.1.0.0, 6.1.0.6, CF27"
  ),
  fix:"PI30620",
  severity:SECURITY_WARNING,
  xss:TRUE
);