IBM WebSphere Portal Improper Access Control Checks (PI07185)

2014-03-26T00:00:00
ID WEBSPHERE_PORTAL_CVE-2013-6730.NASL
Type nessus
Reporter This script is Copyright (C) 2014-2018 Tenable Network Security, Inc.
Modified 2020-07-02T00:00:00

Description

The version of IBM WebSphere Portal on the remote host is affected by a remote information disclosure vulnerability in the WCM Path Traversal component. An attacker can bypass access control checks and search for items of which the user should not have access.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include("compat.inc");

if (description)
{
  script_id(73209);
  script_version("1.4");
  script_cvs_date("Date: 2018/08/06 14:03:14");

  script_cve_id("CVE-2013-6730");
  script_bugtraq_id(65955);

  script_name(english:"IBM WebSphere Portal Improper Access Control Checks (PI07185)");
  script_summary(english:"Checks for installed patches.");

  script_set_attribute(attribute:"synopsis", value:
"The remote Windows host has web portal software installed that is
affected by an information disclosure vulnerability.");
  script_set_attribute(attribute:"description", value:
"The version of IBM WebSphere Portal on the remote host is affected by
a remote information disclosure vulnerability in the WCM Path
Traversal component. An attacker can bypass access control checks and
search for items of which the user should not have access.");
  script_set_attribute(attribute:"see_also", value:"http://www-01.ibm.com/support/docview.wss?uid=swg21665915");
  script_set_attribute(attribute:"solution", value:
"IBM has published Interim Fix PI07185. This fix is a part of 7.0.0.2
CF027 (PI07279) and 8.0.0.1 CF10 (PI08371). Also, a workaround is
available. Refer to IBM's advisory for more information.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
  script_set_attribute(attribute:"exploitability_ease", value:"No exploit is required");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2014/03/03");
  script_set_attribute(attribute:"patch_publication_date", value:"2014/03/03");
  script_set_attribute(attribute:"plugin_publication_date", value:"2014/03/26");

  script_set_attribute(attribute:"potential_vulnerability", value:"true");
  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:ibm:websphere_portal");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2014-2018 Tenable Network Security, Inc.");

  script_dependencies("websphere_portal_installed.nbin");
  script_require_keys("installed_sw/IBM WebSphere Portal", "Settings/ParanoidReport");
  exit(0);
}

include("websphere_portal_version.inc");

# 'wcm.path.traversal.security' setting must be enabled
if (report_paranoia < 2) audit(AUDIT_PARANOID);

websphere_portal_check_version(
  ranges:make_list(
    "6.1.0.0, 6.1.0.6, CF27",
    "6.1.5.0, 6.1.5.3, CF27",
    "7.0.0.0, 7.0.0.2, CF27",
    "8.0.0.0, 8.0.0.1, CF10"
  ),
  fix:"PI07185",
  severity:SECURITY_WARNING
);