Lucene search
+L

Linux Distros Unpatched Vulnerability : CVE-2026-120423

🗓️ 07 Nov 2026 00:00:00Reported by TenableType 
nessus
 nessus
🔗 www.tenable.com👁 5 Views

Improper SRI metadata parsing in undici allows a server to bypass integrity checks.

Related
Refs
Code
ReporterTitlePublishedViews
Family
circl
Circl
CVE-2026-120423
6 Nov 202610:14
–circl
cve
CVE
CVE-2026-120423
6 Nov 202610:08
–cve
cvelist
Cvelist
CVE-2026-120423 undici vulnerable to Subresource Integrity bypass via whitespace in integrity metadata
6 Nov 202610:08
–cvelist
debiancve
Debian CVE
CVE-2026-120423
7 Nov 202622:51
–debiancve
euvd
EUVD
EUVD-2026-118182
6 Nov 202610:08
–euvd
nvd
NVD
CVE-2026-120423
6 Nov 202610:16
–nvd
osv_debian
osv_debian
DEBIAN-CVE-2026-120423
6 Nov 202610:16
–osv_debian
osv_ubuntu
osv_ubuntu
UBUNTU-CVE-2026-120423
6 Nov 202600:00
–osv_ubuntu
ptsecurity
Positive Technologies
PT-2026-137916
6 Nov 202600:00
–ptsecurity
rapid7
Rapid7 Vulnerability Database (full)
CVE-2026-120423: undici: undici is an HTTP client for Node.js
6 Nov 202600:00
–rapid7
Rows per page
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##

include('compat.inc');

if (description)
{
  script_id(377462);
  script_version("1.1");
  script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/07");

  script_cve_id("CVE-2026-120423");

  script_name(english:"Linux Distros Unpatched Vulnerability : CVE-2026-120423");

  script_set_attribute(attribute:"synopsis", value:
"The Linux/Unix host has one or more packages installed with a vulnerability that the vendor indicates will not be
patched.");
  script_set_attribute(attribute:"description", value:
"The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied
patch available.

  - undici is an HTTP client for Node.js. In versions 7.15.0 through 7.30.1 and 8.0.0 through 8.12.3, fetch
    verifies Subresource Integrity metadata by splitting the integrity string on a single space, but the SRI
    grammar separates metadata by ASCII whitespace, which also includes the horizontal tab. An integrity value
    whose digest is preceded by a tab or other ASCII whitespace is parsed as a single unrecognized token and
    skipped, and when no recognized algorithm remains undici treats the integrity list as empty and accepts
    the response, so a server returning a body different from the pinned digest passes the check. An
    application that pins a response with a valid but whitespace-surrounded SRI value receives attacker-
    controlled bytes with no integrity error, and the attacker needs only to control the response body, not
    the integrity metadata. The issue is fixed in undici 7.30.2 and 8.12.4, and users should upgrade to one of
    those versions or later. As a workaround, supply SRI integrity metadata without surrounding whitespace,
    using a single space to separate multiple digests. (CVE-2026-120423)

Note that Nessus relies on the presence of the package as reported by the vendor.");
  script_set_attribute(attribute:"see_also", value:"https://ubuntu.com/security/CVE-2026-120423");
  script_set_attribute(attribute:"solution", value:
"There is no known solution at this time.");
  script_set_attribute(attribute:"agent", value:"unix");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:U/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:U/RC:C");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-120423");

  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");
  script_set_attribute(attribute:"vendor_unpatched", value:"true");

  script_set_attribute(attribute:"vuln_publication_date", value:"2026/11/06");
  script_set_attribute(attribute:"plugin_publication_date", value:"2026/11/07");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:canonical:ubuntu_linux:24.04:-:lts");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:canonical:ubuntu_linux:26.04:-:lts");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:canonical:ubuntu_linux:26.10");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:canonical:ubuntu_linux:node-undici");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"Misc.");

  script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("ssh_get_info2.nasl", "set_linux_os_id.nasl");
  script_require_keys("Host/cpu", "Host/local_checks_enabled", "global_settings/vendor_unpatched", "Host/OS/identifier");
  script_require_ports("Host/OS/Ubuntu Linux-24.04", "Host/OS/Ubuntu Linux-26.04", "Host/OS/Ubuntu Linux-26.10");

  exit(0);
}

if (!get_kb_item("global_settings/vendor_unpatched")) exit(0, "Unpatched Vulnerabilities Detection not active.");
if (!get_kb_item("Host/local_checks_enabled")) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);
if (empty_or_null(get_one_kb_item("Host/Debian/dpkg-l"))) audit(AUDIT_PACKAGE_LIST_MISSING);

include('linux_unpatched.inc');

var distro_constraints_array = {
  "Ubuntu Linux-24.04": {
    "package_manager": "dpkg-l",
    "constraints": [
      {
        "release": "24.04",
        "pkgs": [
          {"reference": "node-undici"}
        ]
      }
    ]
  },
  "Ubuntu Linux-26.04": {
    "package_manager": "dpkg-l",
    "constraints": [
      {
        "release": "26.04",
        "pkgs": [
          {"reference": "node-undici"}
        ]
      }
    ]
  },
  "Ubuntu Linux-26.10": {
    "package_manager": "dpkg-l",
    "constraints": [
      {
        "release": "26.10",
        "pkgs": [
          {"reference": "node-undici"}
        ]
      }
    ]
  }
};

var distro_constraints_values = linux_unpatched::get_distro_constraints(distro_constraints_arr:distro_constraints_array);
if (empty_or_null(distro_constraints_values)) audit(AUDIT_HOST_NOT, 'affected');

var third_party_support = get_kb_item('Host/OS/extended-third-party');
if (!empty_or_null(third_party_support)) {
    var third_party_vendors = distro_constraints_values['third_party'];
    if (!empty_or_null(third_party_vendors)) {
        var vendor;
        foreach vendor (third_party_vendors) {
            if (vendor == third_party_support) exit(0, 'A third party management patch is available for this vulnerability from ' + vendor + '.\n');
        }
    }
}

var report = linux_unpatched::check_unpatched_constraints(distro_constraints_values:distro_constraints_values);

if (!empty_or_null(report))
{
  security_report_v4(
      port       : 0,
      severity   : SECURITY_WARNING,
      extra      : report
  );
  exit(0);
}
else
{
  audit(AUDIT_HOST_NOT, 'affected');
}

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

07 Nov 2026 00:00Current
5.8Medium risk
Vulners AI Score5.8
CVSS 3.15.9
EPSS0.00134
5