Apache Tomcat 7.0.x < 7.0.28 Multiple DoS

2012-11-21T00:00:00
ID TOMCAT_7_0_28.NASL
Type nessus
Reporter Tenable
Modified 2018-11-15T00:00:00

Description

According to its self-reported version number, the instance of Apache Tomcat 7.0 listening on the remote host is prior to 7.0.28. It is, therefore, affected by the following vulnerabilities :

  • A flaw exists within the parseHeaders() function that allows an attacker, via a crafted header, to cause a remote denial of service. (CVE-2012-2733)

  • An error exists related to the 'NIO' connector when HTTPS and 'sendfile' are enabled that can force the application into an infinite loop. (CVE-2012-4534)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include("compat.inc");

if (description)
{
  script_id(62985);
  script_version("1.18");
  script_cvs_date("Date: 2018/11/15 20:50:25");

  script_cve_id("CVE-2012-2733", "CVE-2012-4534");
  script_bugtraq_id(56402, 56813);

  script_name(english:"Apache Tomcat 7.0.x < 7.0.28 Multiple DoS");
  script_summary(english:"Checks the Apache Tomcat version.");

  script_set_attribute(attribute:"synopsis", value:
"The remote Apache Tomcat server is affected by multiple remote denial
of service vulnerabilities.");
  script_set_attribute(attribute:"description", value:
"According to its self-reported version number, the instance of Apache
Tomcat 7.0 listening on the remote host is prior to 7.0.28. It is,
therefore, affected by the following vulnerabilities :

  - A flaw exists within the parseHeaders() function that
    allows an attacker, via a crafted header, to cause a
    remote denial of service. (CVE-2012-2733)

  - An error exists related to the 'NIO' connector when
    HTTPS and 'sendfile' are enabled that can force the
    application into an infinite loop. (CVE-2012-4534)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.");
  script_set_attribute(attribute:"see_also", value:"http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.28");
  script_set_attribute(attribute:"see_also", value:"https://seclists.org/fulldisclosure/2012/Dec/72");
  script_set_attribute(attribute:"solution", value:"Upgrade to Apache Tomcat version 7.0.28 or later.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P");
  script_set_cvss_temporal_vector("CVSS2#E:H/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:H/RL:O/RC:C");
  script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"true");
  script_set_attribute(attribute:"exploited_by_malware", value:"true");

  script_set_attribute(attribute:"vuln_publication_date", value:"2012/07/02");
  script_set_attribute(attribute:"patch_publication_date", value:"2012/07/02");
  script_set_attribute(attribute:"plugin_publication_date", value:"2012/11/21");

  script_set_attribute(attribute:"plugin_type", value:"remote");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:apache:tomcat");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"Web Servers");

  script_copyright(english:"This script is Copyright (C) 2012-2018 Tenable Network Security, Inc.");

  script_dependencies("tomcat_error_version.nasl");
  script_require_ports("Services/www", 8080);
  script_require_keys("installed_sw/Apache Tomcat", "Settings/ParanoidReport");

  exit(0);
}

include("tomcat_version.inc");

tomcat_check_version(fixed:"7.0.28", min:"7.0.0", severity:SECURITY_WARNING, granularity_regex:"^7(\.0)?$");