Squid 5.x < 7.7 Stack-based Buffer Overflow (SQUID-2026:7)
| Reporter | Title | Published | Views | Family All 7 |
|---|---|---|---|---|
| CVE-2026-104786 | 3 Nov 202600:00 | – | cve | |
| [SECURITY] [DSA 6606-1] squid security update | 3 Nov 202616:03 | – | debian | |
| CVE-2026-104786 | 4 Nov 202603:22 | – | debiancve | |
| DEBIAN-CVE-2026-104786 | 3 Nov 202617:47 | – | osv_debian | |
| UBUNTU-CVE-2026-104786 | 3 Nov 202600:00 | – | osv_ubuntu | |
| CVE-2026-104786 | 3 Nov 202600:00 | – | ubuntucve | |
| Linux Distros Unpatched Vulnerability : CVE-2026-104786 | 3 Nov 202600:00 | – | nessus |
| Source | Link |
|---|---|
| nessus | www.nessus.org/u |
| cve | www.cve.mitre.org/cgi-bin/cvename.cgi |
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(377052);
script_version("1.1");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/06");
script_cve_id("CVE-2026-104786");
script_xref(name:"IAVB", value:"2026-B-0322");
script_name(english:"Squid 5.x < 7.7 Stack-based Buffer Overflow (SQUID-2026:7)");
script_set_attribute(attribute:"synopsis", value:
"The remote proxy server is affected by a stack-based buffer overflow vulnerability.");
script_set_attribute(attribute:"description", value:
"The version of Squid on the remote host is 5.x, 6.x or 7.x prior to 7.7. It is, therefore, affected by a stack-based
buffer overflow vulnerability:
- Due to an Improper Input Validation bug, Squid is vulnerable to a stack-based buffer overflow attack against HTTP
authentication. This problem allows a trusted client to perform an out-of-bounds write when Squid is configured to
authenticate with a peer server using client provided Basic authentication credentials. This attack is limited to
Squid deployments passing client supplied Basic authentication credentials to a cache_peer. (CVE-2026-104786)
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
# https://github.com/squid-cache/squid/security/advisories/GHSA-j9pf-q9f6-v44c
script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?63d1ba32");
script_set_attribute(attribute:"solution", value:
"Upgrade to Squid version 7.7 or later, or apply the patch referenced in the vendor advisory.");
script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:P");
script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-104786");
script_cwe_id(20, 121);
script_set_attribute(attribute:"vuln_publication_date", value:"2026/09/12");
script_set_attribute(attribute:"patch_publication_date", value:"2026/08/24");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/11/06");
script_set_attribute(attribute:"potential_vulnerability", value:"true");
script_set_attribute(attribute:"plugin_type", value:"remote");
script_set_attribute(attribute:"cpe", value:"cpe:/a:squid-cache:squid");
script_set_attribute(attribute:"stig_severity", value:"I");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"Firewalls");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("squid_version.nasl");
script_require_keys("installed_sw/Squid", "Settings/ParanoidReport");
script_require_ports("Services/http_proxy", 3128, 8080);
exit(0);
}
include('vdf.inc');
if (report_paranoia < 2)
audit(AUDIT_PARANOID);
# @tvdl-content
var vuln_data = {
'metadata': {'spec_version': '1.0'},
'checks': [
{
'product': {'name': 'Squid', 'type': 'app'},
'check_algorithm': 'default',
'potential_vulnerability': {
'low_fidelity': {'context': 'unreliable remote detection'}
},
'requires': [
{'scope': 'target', 'match': {'paranoia': true}}
],
'constraints': [
{'min_version': '5.0', 'fixed_version': '7.7'}
]
}
]
};
var result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_WARNING);
vdf::handle_check_and_report_errors(vdf_result:result);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
06 Nov 2026 00:00Current
6.5Medium risk
Vulners AI Score6.5