Solaris 9 (x86) : 114242-55

2004-07-12T00:00:00
ID SOLARIS9_X86_114242.NASL
Type nessus
Reporter Tenable
Modified 2011-09-18T00:00:00

Description

SunOS 5.9_x86: ldap library Patch. Date this patch was last updated by Sun : Jan/05/10

                                        
                                            # @DEPRECATED@
#
# This script has been deprecated as the associated patch is not
# currently a recommended security fix.
#
# Disabled on 2011/09/17.

#
# (C) Tenable Network Security, Inc.
#
#

if ( ! defined_func("bn_random") ) exit(0);
include("compat.inc");

if(description)
{
 script_id(13595);
 script_version("$Revision: 1.62 $");

 script_name(english: "Solaris 9 (x86) : 114242-55");
 script_osvdb_id(36594, 52557, 55049);
 script_cve_id("CVE-2007-3458", "CVE-2009-2029");
 script_set_attribute(attribute: "synopsis", value:
"The remote host is missing Sun Security Patch number 114242-55");
 script_set_attribute(attribute: "description", value:
'SunOS 5.9_x86: ldap library Patch.
Date this patch was last updated by Sun : Jan/05/10');
 script_set_attribute(attribute: "solution", value:
"You should install this patch for your system to be up-to-date.");
 script_set_attribute(attribute: "see_also", value:
"https://getupdates.oracle.com/readme/114242-55");
 script_set_attribute(attribute: "cvss_vector", value: "CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P");
 script_set_attribute(attribute:"plugin_publication_date", value: "2004/07/12");
 script_cvs_date("$Date: 2011/09/18 01:40:37 $");
 script_set_attribute(attribute:"vuln_publication_date", value: "2007/06/26");
 script_end_attributes();

 script_summary(english: "Check for patch 114242-55");
 script_category(ACT_GATHER_INFO);
 script_copyright(english:"This script is Copyright (C) 2004-2011 Tenable Network Security, Inc.");
 family["english"] = "Solaris Local Security Checks";
 script_family(english:family["english"]);
 
 script_dependencies("ssh_get_info.nasl");
 script_require_keys("Host/Solaris/showrev");
 exit(0);
}



# Deprecated.
exit(0, "The associated patch is not currently a recommended security fix.");

include("solaris.inc");

e +=  solaris_check_patch(release:"5.9_x86", arch:"i386", patch:"114242-55", obsoleted_by:"115696-02 ", package:"SUNWarc", version:"11.9.0,REV=2002.11.04.02.51");
e +=  solaris_check_patch(release:"5.9_x86", arch:"i386", patch:"114242-55", obsoleted_by:"115696-02 ", package:"SUNWcsl", version:"11.9.0,REV=2002.11.04.02.51");
e +=  solaris_check_patch(release:"5.9_x86", arch:"i386", patch:"114242-55", obsoleted_by:"115696-02 ", package:"SUNWcstl", version:"11.9.0,REV=2002.11.04.02.51");
e +=  solaris_check_patch(release:"5.9_x86", arch:"i386", patch:"114242-55", obsoleted_by:"115696-02 ", package:"SUNWcsu", version:"11.9.0,REV=2002.11.04.02.51");
e +=  solaris_check_patch(release:"5.9_x86", arch:"i386", patch:"114242-55", obsoleted_by:"115696-02 ", package:"SUNWhea", version:"11.9.0,REV=2002.11.04.02.51");
e +=  solaris_check_patch(release:"5.9_x86", arch:"i386", patch:"114242-55", obsoleted_by:"115696-02 ", package:"SUNWnisu", version:"11.9.0,REV=2002.11.04.02.51");
if ( e < 0 ) { 
	if ( NASL_LEVEL < 3000 ) 
	   security_warning(0);
	else  
	   security_warning(port:0, extra:solaris_get_report());
	exit(0); 
} 
exit(0, "Host is not affected");