MS14-049: Vulnerability in Windows Installer Service Could Allow Elevation of Privilege (2962490)

2014-08-12T00:00:00
ID SMB_NT_MS14-049.NASL
Type nessus
Reporter Tenable
Modified 2017-07-28T00:00:00

Description

A privilege escalation vulnerability exists on the remote Windows host due to improper handling of the repair functionality in the Windows installer service. A local attacker could exploit this vulnerability to execute arbitrary code on the remote host under the privileges of the system administrator.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include('compat.inc');

if (description)
{
  script_id(77167);
  script_version("$Revision: 1.7 $");
  script_cvs_date("$Date: 2017/07/28 20:48:40 $");

  script_cve_id("CVE-2014-1814");
  script_bugtraq_id(69112);
  script_osvdb_id(109940);
  script_xref(name:"MSFT", value:"MS14-049");
  script_xref(name:"MSKB", value:"2918614");

  script_name(english:"MS14-049: Vulnerability in Windows Installer Service Could Allow Elevation of Privilege (2962490)");
  script_summary(english:"Checks the version of msi.dll / consent.exe.");

  script_set_attribute(attribute:"synopsis", value:
"The remote Windows host is affected by a privilege escalation
vulnerability.");
  script_set_attribute(attribute:"description", value:
"A privilege escalation vulnerability exists on the remote Windows host
due to improper handling of the repair functionality in the Windows
installer service. A local attacker could exploit this vulnerability
to execute arbitrary code on the remote host under the privileges of
the system administrator.");
  script_set_attribute(attribute:"see_also", value:"https://technet.microsoft.com/library/security/MS14-049");
  script_set_attribute(attribute:"solution", value:
"Microsoft has released a set of patches for 2003, Vista, 2008, 7, 2008
R2, 8, 2012, 8.1, and 2012 R2.");
  script_set_cvss_base_vector("CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C");
  script_set_cvss_temporal_vector("CVSS2#E:ND/RL:OF/RC:C");
  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2014/08/12");
  script_set_attribute(attribute:"patch_publication_date", value:"2014/08/12");
  script_set_attribute(attribute:"plugin_publication_date", value:"2014/08/12");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:microsoft:windows");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"Windows : Microsoft Bulletins");

  script_copyright(english:"This script is Copyright (C) 2014-2017 Tenable Network Security, Inc.");

  script_dependencies("smb_hotfixes.nasl", "ms_bulletin_checks_possible.nasl");
  script_require_keys("SMB/MS_Bulletin_Checks/Possible");
  script_require_ports(139, 445, 'Host/patch_management_checks');

  exit(0);
}

include("audit.inc");
include("smb_hotfixes_fcheck.inc");
include("smb_hotfixes.inc");
include("smb_func.inc");
include("misc_func.inc");

get_kb_item_or_exit("SMB/MS_Bulletin_Checks/Possible");

bulletin = 'MS14-049';
kb  = "2918614";
kbs = make_list(kb);

if (get_kb_item("Host/patch_management_checks")) hotfix_check_3rd_party(bulletin:bulletin, kbs:kbs, severity:SECURITY_HOLE);

get_kb_item_or_exit("SMB/Registry/Enumerated");
get_kb_item_or_exit("SMB/WindowsVersion", exit_code:1);

if (hotfix_check_sp_range(win2003:'2', vista:'2', win7:'1', win8:'0', win81:'0') <= 0) audit(AUDIT_OS_SP_NOT_VULN);

share = hotfix_get_systemdrive(as_share:TRUE, exit_on_fail:TRUE);
if (!is_accessible_share(share:share)) audit(AUDIT_SHARE_FAIL, share);

if (
  # Windows 8.1 / Windows Server 2012 R2 with KB2919355 applied
  hotfix_is_vulnerable(os:"6.3", arch:"x86", sp:0, file:"consent.exe", version:"6.3.9600.17198", min_version:"6.3.9600.17031", dir:"\system32", bulletin:bulletin, kb:kb) ||
  hotfix_is_vulnerable(os:"6.3", arch:"x64", sp:0, file:"msi.dll", version:"5.0.9600.17198", min_version:"5.0.9600.16000", dir:"\system32", bulletin:bulletin, kb:kb) ||

  # Windows 8 / Windows Server 2012
  hotfix_is_vulnerable(os:"6.2", sp:0, file:"msi.dll", version:"5.0.9200.21139", min_version:"5.0.9200.20000", dir:"\system32", bulletin:bulletin, kb:kb) ||
  hotfix_is_vulnerable(os:"6.2", sp:0, file:"msi.dll", version:"5.0.9200.17022", min_version:"5.0.9200.16000", dir:"\system32", bulletin:bulletin, kb:kb) ||

  # Windows 7 / Server 2008 R2
  hotfix_is_vulnerable(os:"6.1", sp:1, file:"msi.dll", version:"5.0.7601.22708", min_version:"5.0.7601.22000", dir:"\system32", bulletin:bulletin, kb:kb) ||
  hotfix_is_vulnerable(os:"6.1", sp:1, file:"msi.dll", version:"5.0.7601.18493", min_version:"5.0.7600.18000", dir:"\system32", bulletin:bulletin, kb:kb) ||

  # Vista / Windows Server 2008
  hotfix_is_vulnerable(os:"6.0", sp:2, file:"msi.dll", version:"4.5.6002.23415", min_version:"4.5.6002.23000", dir:"\system32", bulletin:bulletin, kb:kb) ||
  hotfix_is_vulnerable(os:"6.0", sp:2, file:"msi.dll", version:"4.5.6002.19116", min_version:"4.5.6002.18000", dir:"\system32", bulletin:bulletin, kb:kb) ||

  # Windows 2003
  hotfix_is_vulnerable(os:"5.2", sp:2, file:"msi.dll", version:"4.5.6002.23415", dir:"\System32", bulletin:bulletin, kb:kb)
)
{
  set_kb_item(name:'SMB/Missing/'+bulletin, value:TRUE);
  hotfix_security_hole();
  hotfix_check_fversion_end();
  exit(0);
}
else
{
  hotfix_check_fversion_end();
  audit(AUDIT_HOST_NOT, 'affected');
}