MS11-033: Vulnerability in WordPad Text Converters Could Allow Remote Code Execution (2485663)

2011-04-13T00:00:00
ID SMB_NT_MS11-033.NASL
Type nessus
Reporter Tenable
Modified 2018-08-03T00:00:00

Description

The installed version of Microsoft WordPad includes text converters that do not correctly parse certain fields in a Word document.

If an attacker can trick a user on the affected system into opening a specially crafted Word document using WordPad, this issue could be leveraged to execute arbitrary code subject to the user's privileges.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include("compat.inc");

if (description)
{
  script_id(53390);
  script_version("1.18");
  script_cvs_date("Date: 2018/08/03 11:35:09");

  script_cve_id("CVE-2011-0028");
  script_bugtraq_id(47236);
  script_xref(name:"MSFT", value:"MS11-033");
  script_xref(name:"IAVB", value:"2011-B-0048");
  script_xref(name:"MSKB", value:"2485663");

  script_name(english:"MS11-033: Vulnerability in WordPad Text Converters Could Allow Remote Code Execution (2485663)");
  script_summary(english:"Checks version of Mswrd8.wpc");

  script_set_attribute(
    attribute:"synopsis",
    value:
"Arbitrary code can be executed on the remote host through the installed
version of Microsoft WordPad."
  );
  script_set_attribute(
    attribute:"description",
    value:
"The installed version of Microsoft WordPad includes text converters
that do not correctly parse certain fields in a Word document.

If an attacker can trick a user on the affected system into opening a
specially crafted Word document using WordPad, this issue could be
leveraged to execute arbitrary code subject to the user's privileges."
  );
  script_set_attribute(attribute:"see_also", value:"https://technet.microsoft.com/library/security/ms11-033");
  script_set_attribute(attribute:"solution", value:"Microsoft has released a set of patches for XP and 2003.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C");
  script_set_cvss_temporal_vector("CVSS2#E:H/RL:OF/RC:C");
  script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"true");
  script_set_attribute(attribute:"exploited_by_malware", value:"true");

  script_set_attribute(attribute:"vuln_publication_date", value:"2011/04/12");
  script_set_attribute(attribute:"patch_publication_date", value:"2011/04/12");
  script_set_attribute(attribute:"plugin_publication_date", value:"2011/04/13");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:microsoft:windows");
  script_set_attribute(attribute:"stig_severity", value:"II");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"Windows : Microsoft Bulletins");

  script_copyright(english:"This script is Copyright (C) 2011-2018 Tenable Network Security, Inc.");

  script_dependencies("smb_nt_ms02-031.nasl", "ms_bulletin_checks_possible.nasl");
  script_require_keys("SMB/MS_Bulletin_Checks/Possible");
  script_require_ports(139, 445, 'Host/patch_management_checks');

  exit(0);
}


include("audit.inc");
include("smb_hotfixes_fcheck.inc");
include("smb_hotfixes.inc");
include("smb_func.inc");
include("misc_func.inc");


get_kb_item_or_exit("SMB/MS_Bulletin_Checks/Possible");

bulletin = 'MS11-033';
kb = '2485663';

kbs = make_list(kb);
if (get_kb_item("Host/patch_management_checks")) hotfix_check_3rd_party(bulletin:bulletin, kbs:kbs, severity:SECURITY_HOLE);


get_kb_item_or_exit("SMB/Registry/Enumerated");
get_kb_item_or_exit("SMB/WindowsVersion", exit_code:1);

if (hotfix_check_sp_range(xp:'3', win2003:'2') <= 0) audit(AUDIT_OS_SP_NOT_VULN);

path = hotfix_get_programfilesdir() + "\Windows NT\Accessories";

share = hotfix_path2share(path:path);
if (!is_accessible_share(share:share)) audit(AUDIT_SHARE_FAIL, share);

if (
  # Windows 2003
  hotfix_is_vulnerable(os:"5.2", sp:2, file:"Mswrd8.wpc", path:path, version:"2011.1.31.10", bulletin:bulletin, kb:kb) ||

  # Windows XP
  hotfix_is_vulnerable(os:"5.1", sp:3, file:"Mswrd8.wpc", path:path, version:"2011.1.31.10", bulletin:bulletin, kb:kb)
)
{
  set_kb_item(name:"SMB/Missing/"+bulletin, value:TRUE);
  hotfix_security_hole();
  hotfix_check_fversion_end();
  exit(0);
}
else
{
  hotfix_check_fversion_end();
  audit(AUDIT_HOST_NOT, 'affected');
}