logo
DATABASE RESOURCES PRICING ABOUT US

Slackware Linux 15.0 / current php Multiple Vulnerabilities (SSA:2022-048-02)

Description

The version of php installed on the remote host is prior to 7.4.28 / 8.0.16 / 8.1.3. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2022-048-02 advisory. - In PHP versions 7.4.x below 7.4.28, 8.0.x below 8.0.16, and 8.1.x below 8.1.3, when using filter functions with FILTER_VALIDATE_FLOAT filter and min/max limits, if the filter fails, there is a possibility to trigger use of allocated memory after free, which can result it crashes, and potentially in overwrite of other memory chunks and RCE. This issue affects: code that uses FILTER_VALIDATE_FLOAT with min/max limits. (CVE-2021-21708) Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Related