Lucene search

K
nessusThis script is Copyright (C) 2023-2024 and is owned by Tenable, Inc. or an Affiliate thereof.REDHAT-RHSA-2023-1130.NASL
HistoryMar 09, 2023 - 12:00 a.m.

RHEL 8 : kernel (RHSA-2023:1130)

2023-03-0900:00:00
This script is Copyright (C) 2023-2024 and is owned by Tenable, Inc. or an Affiliate thereof.
www.tenable.com
58
redhat enterprise linux 8
kernel
memory corruption
usb ethernet device
net
cpu
soft lockup
vulnerability
mremap.c
use-after-free
ipv6
panic
fib6_rule_suppress

8 High

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

41.2%

The remote Redhat Enterprise Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2023:1130 advisory.

  • kernel: memory corruption in AX88179_178A based USB ethernet device. (CVE-2022-2964)

  • kernel: net: CPU soft lockup in TC mirred egress-to-ingress action (CVE-2022-4269)

  • kernel: mm/mremap.c use-after-free vulnerability (CVE-2022-41222)

  • kernel: IPv6: panic in fib6_rule_suppress when fib6_rule_lookup fails (CVE-2023-3022)

Note that Nessus has not tested for these issues but has instead relied only on the application’s self-reported version number.

#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
#
# The descriptive text and package checks in this plugin were
# extracted from Red Hat Security Advisory RHSA-2023:1130. The text
# itself is copyright (C) Red Hat, Inc.
##

include('deprecated_nasl_level.inc');
include('compat.inc');

if (description)
{
  script_id(172370);
  script_version("1.4");
  script_set_attribute(attribute:"plugin_modification_date", value:"2024/04/23");

  script_cve_id(
    "CVE-2022-2964",
    "CVE-2022-4269",
    "CVE-2023-3022",
    "CVE-2022-41222"
  );
  script_xref(name:"RHSA", value:"2023:1130");

  script_name(english:"RHEL 8 : kernel (RHSA-2023:1130)");

  script_set_attribute(attribute:"synopsis", value:
"The remote Red Hat host is missing one or more security updates for kernel.");
  script_set_attribute(attribute:"description", value:
"The remote Redhat Enterprise Linux 8 host has packages installed that are affected by multiple vulnerabilities as
referenced in the RHSA-2023:1130 advisory.

  - kernel: memory corruption in AX88179_178A based USB ethernet device. (CVE-2022-2964)

  - kernel: net: CPU soft lockup in TC mirred egress-to-ingress action (CVE-2022-4269)

  - kernel: mm/mremap.c use-after-free vulnerability (CVE-2022-41222)

  - kernel: IPv6: panic in fib6_rule_suppress when fib6_rule_lookup fails (CVE-2023-3022)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version
number.");
  # https://access.redhat.com/security/data/csaf/v2/advisories/2023/rhsa-2023_1130.json
  script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?b83c1ff9");
  script_set_attribute(attribute:"see_also", value:"https://access.redhat.com/errata/RHSA-2023:1130");
  script_set_attribute(attribute:"see_also", value:"https://access.redhat.com/security/updates/classification/#important");
  script_set_attribute(attribute:"see_also", value:"https://bugzilla.redhat.com/show_bug.cgi?id=2067482");
  script_set_attribute(attribute:"see_also", value:"https://bugzilla.redhat.com/show_bug.cgi?id=2138818");
  script_set_attribute(attribute:"see_also", value:"https://bugzilla.redhat.com/show_bug.cgi?id=2150272");
  script_set_attribute(attribute:"solution", value:
"Update the RHEL kernel package based on the guidance in RHSA-2023:1130.");
  script_set_cvss_base_vector("CVSS2#AV:L/AC:L/Au:S/C:C/I:C/A:C");
  script_set_cvss_temporal_vector("CVSS2#E:POC/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:P/RL:O/RC:C");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2022-2964");

  script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"true");
  script_cwe_id(119, 416, 833, 843);
  script_set_attribute(attribute:"vendor_severity", value:"Important");

  script_set_attribute(attribute:"vuln_publication_date", value:"2022/03/07");
  script_set_attribute(attribute:"patch_publication_date", value:"2023/03/07");
  script_set_attribute(attribute:"plugin_publication_date", value:"2023/03/09");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:redhat:enterprise_linux:8");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:redhat:rhel_eus:8.6");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:bpftool");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-core");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-cross-headers");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-debug");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-debug-core");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-debug-devel");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-debug-modules");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-debug-modules-extra");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-devel");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-headers");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-modules");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-modules-extra");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-tools");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs-devel");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-core");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-devel");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-modules");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-modules-extra");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:perf");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:redhat:enterprise_linux:python3-perf");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"Red Hat Local Security Checks");

  script_copyright(english:"This script is Copyright (C) 2023-2024 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("ssh_get_info.nasl", "redhat_repos.nasl", "linux_alt_patch_detect.nasl");
  script_require_keys("Host/local_checks_enabled", "Host/RedHat/release", "Host/RedHat/rpm-list", "Host/cpu");

  exit(0);
}


include('rpm.inc');
include('rhel.inc');
include('ksplice.inc');

if (!get_kb_item('Host/local_checks_enabled')) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);
var os_release = get_kb_item('Host/RedHat/release');
if (isnull(os_release) || 'Red Hat' >!< os_release) audit(AUDIT_OS_NOT, 'Red Hat');
var os_ver = pregmatch(pattern: "Red Hat Enterprise Linux.*release ([0-9]+(\.[0-9]+)?)", string:os_release);
if (isnull(os_ver)) audit(AUDIT_UNKNOWN_APP_VER, 'Red Hat');
os_ver = os_ver[1];
if (!rhel_check_release_list(operator: 'ge', os_version: os_ver, rhel_versions: ['8','8.6'])) audit(AUDIT_OS_NOT, 'Red Hat 8.x / 8.x', 'Red Hat ' + os_ver);

if (!get_kb_item('Host/RedHat/rpm-list')) audit(AUDIT_PACKAGE_LIST_MISSING);

var cpu = get_kb_item('Host/cpu');
if (isnull(cpu)) audit(AUDIT_UNKNOWN_ARCH);
if ('x86_64' >!< cpu && cpu !~ "^i[3-6]86$" && 's390' >!< cpu && 'aarch64' >!< cpu && 'ppc' >!< cpu) audit(AUDIT_LOCAL_CHECKS_NOT_IMPLEMENTED, 'Red Hat', cpu);

if (get_one_kb_item('Host/ksplice/kernel-cves'))
{
  rm_kb_item(name:'Host/uptrack-uname-r');
  var cve_list = make_list('CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022');
  if (ksplice_cves_check(cve_list))
  {
    audit(AUDIT_PATCH_INSTALLED, 'KSplice hotfix for RHSA-2023:1130');
  }
  else
  {
    __rpm_report = ksplice_reporting_text();
  }
}

var constraints = [
  {
    'repo_relative_urls': [
      'content/aus/rhel8/8.6/x86_64/baseos/debug',
      'content/aus/rhel8/8.6/x86_64/baseos/os',
      'content/aus/rhel8/8.6/x86_64/baseos/source/SRPMS',
      'content/e4s/rhel8/8.6/ppc64le/baseos/debug',
      'content/e4s/rhel8/8.6/ppc64le/baseos/os',
      'content/e4s/rhel8/8.6/ppc64le/baseos/source/SRPMS',
      'content/e4s/rhel8/8.6/x86_64/baseos/debug',
      'content/e4s/rhel8/8.6/x86_64/baseos/os',
      'content/e4s/rhel8/8.6/x86_64/baseos/source/SRPMS',
      'content/eus/rhel8/8.6/aarch64/baseos/debug',
      'content/eus/rhel8/8.6/aarch64/baseos/os',
      'content/eus/rhel8/8.6/aarch64/baseos/source/SRPMS',
      'content/eus/rhel8/8.6/aarch64/codeready-builder/debug',
      'content/eus/rhel8/8.6/aarch64/codeready-builder/os',
      'content/eus/rhel8/8.6/aarch64/codeready-builder/source/SRPMS',
      'content/eus/rhel8/8.6/ppc64le/baseos/debug',
      'content/eus/rhel8/8.6/ppc64le/baseos/os',
      'content/eus/rhel8/8.6/ppc64le/baseos/source/SRPMS',
      'content/eus/rhel8/8.6/ppc64le/codeready-builder/debug',
      'content/eus/rhel8/8.6/ppc64le/codeready-builder/os',
      'content/eus/rhel8/8.6/ppc64le/codeready-builder/source/SRPMS',
      'content/eus/rhel8/8.6/s390x/baseos/debug',
      'content/eus/rhel8/8.6/s390x/baseos/os',
      'content/eus/rhel8/8.6/s390x/baseos/source/SRPMS',
      'content/eus/rhel8/8.6/s390x/codeready-builder/debug',
      'content/eus/rhel8/8.6/s390x/codeready-builder/os',
      'content/eus/rhel8/8.6/s390x/codeready-builder/source/SRPMS',
      'content/eus/rhel8/8.6/x86_64/baseos/debug',
      'content/eus/rhel8/8.6/x86_64/baseos/os',
      'content/eus/rhel8/8.6/x86_64/baseos/source/SRPMS',
      'content/eus/rhel8/8.6/x86_64/codeready-builder/debug',
      'content/eus/rhel8/8.6/x86_64/codeready-builder/os',
      'content/eus/rhel8/8.6/x86_64/codeready-builder/source/SRPMS',
      'content/tus/rhel8/8.6/x86_64/baseos/debug',
      'content/tus/rhel8/8.6/x86_64/baseos/os',
      'content/tus/rhel8/8.6/x86_64/baseos/source/SRPMS'
    ],
    'pkgs': [
      {'reference':'bpftool-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-core-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-cross-headers-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-debug-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-debug-core-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-debug-devel-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-debug-modules-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-debug-modules-extra-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-devel-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-headers-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2023-3022']},
      {'reference':'kernel-modules-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-modules-extra-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-4.18.0-372.46.1.el8_6', 'sp':'6', 'cpu':'aarch64', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-4.18.0-372.46.1.el8_6', 'sp':'6', 'cpu':'ppc64le', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-4.18.0-372.46.1.el8_6', 'sp':'6', 'cpu':'x86_64', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-devel-4.18.0-372.46.1.el8_6', 'sp':'6', 'cpu':'aarch64', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-devel-4.18.0-372.46.1.el8_6', 'sp':'6', 'cpu':'ppc64le', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-devel-4.18.0-372.46.1.el8_6', 'sp':'6', 'cpu':'x86_64', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-zfcpdump-4.18.0-372.46.1.el8_6', 'sp':'6', 'cpu':'s390x', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-zfcpdump-core-4.18.0-372.46.1.el8_6', 'sp':'6', 'cpu':'s390x', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-zfcpdump-devel-4.18.0-372.46.1.el8_6', 'sp':'6', 'cpu':'s390x', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-zfcpdump-modules-4.18.0-372.46.1.el8_6', 'sp':'6', 'cpu':'s390x', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-zfcpdump-modules-extra-4.18.0-372.46.1.el8_6', 'sp':'6', 'cpu':'s390x', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'perf-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'python3-perf-4.18.0-372.46.1.el8_6', 'sp':'6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']}
    ]
  },
  {
    'repo_relative_urls': [
      'content/dist/layered/rhel8/ppc64le/rhv-mgmt-agent/4/debug',
      'content/dist/layered/rhel8/ppc64le/rhv-mgmt-agent/4/os',
      'content/dist/layered/rhel8/ppc64le/rhv-mgmt-agent/4/source/SRPMS',
      'content/dist/layered/rhel8/ppc64le/rhv-tools/4/debug',
      'content/dist/layered/rhel8/ppc64le/rhv-tools/4/os',
      'content/dist/layered/rhel8/ppc64le/rhv-tools/4/source/SRPMS',
      'content/dist/layered/rhel8/x86_64/rhv-mgmt-agent/4/debug',
      'content/dist/layered/rhel8/x86_64/rhv-mgmt-agent/4/os',
      'content/dist/layered/rhel8/x86_64/rhv-mgmt-agent/4/source/SRPMS',
      'content/dist/layered/rhel8/x86_64/rhv-tools/4/debug',
      'content/dist/layered/rhel8/x86_64/rhv-tools/4/os',
      'content/dist/layered/rhel8/x86_64/rhv-tools/4/source/SRPMS',
      'content/dist/layered/rhel8/x86_64/rhvh-build/4/debug',
      'content/dist/layered/rhel8/x86_64/rhvh-build/4/os',
      'content/dist/layered/rhel8/x86_64/rhvh-build/4/source/SRPMS',
      'content/dist/layered/rhel8/x86_64/rhvh/4/debug',
      'content/dist/layered/rhel8/x86_64/rhvh/4/os',
      'content/dist/layered/rhel8/x86_64/rhvh/4/source/SRPMS'
    ],
    'pkgs': [
      {'reference':'bpftool-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-core-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-cross-headers-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-debug-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-debug-core-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-debug-devel-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-debug-modules-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-debug-modules-extra-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-devel-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-headers-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2023-3022']},
      {'reference':'kernel-modules-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-modules-extra-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-4.18.0-372.46.1.el8_6', 'cpu':'aarch64', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-4.18.0-372.46.1.el8_6', 'cpu':'ppc64le', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-4.18.0-372.46.1.el8_6', 'cpu':'x86_64', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-devel-4.18.0-372.46.1.el8_6', 'cpu':'aarch64', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-devel-4.18.0-372.46.1.el8_6', 'cpu':'ppc64le', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-tools-libs-devel-4.18.0-372.46.1.el8_6', 'cpu':'x86_64', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-zfcpdump-4.18.0-372.46.1.el8_6', 'cpu':'s390x', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-zfcpdump-core-4.18.0-372.46.1.el8_6', 'cpu':'s390x', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-zfcpdump-devel-4.18.0-372.46.1.el8_6', 'cpu':'s390x', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-zfcpdump-modules-4.18.0-372.46.1.el8_6', 'cpu':'s390x', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'kernel-zfcpdump-modules-extra-4.18.0-372.46.1.el8_6', 'cpu':'s390x', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'perf-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']},
      {'reference':'python3-perf-4.18.0-372.46.1.el8_6', 'release':'8', 'rpm_spec_vers_cmp':TRUE, 'cves':['CVE-2022-2964', 'CVE-2022-4269', 'CVE-2022-41222', 'CVE-2023-3022']}
    ]
  }
];

var applicable_repo_urls = rhel_determine_applicable_repository_urls(constraints:constraints);
if(applicable_repo_urls == RHEL_REPOS_NO_OVERLAP_MESSAGE) exit(0, RHEL_REPO_NOT_ENABLED);

var flag = 0;
foreach var constraint_array ( constraints ) {
  var repo_relative_urls = NULL;
  if (!empty_or_null(constraint_array['repo_relative_urls'])) repo_relative_urls = constraint_array['repo_relative_urls'];
  foreach var pkg ( constraint_array['pkgs'] ) {
    var reference = NULL;
    var _release = NULL;
    var sp = NULL;
    var _cpu = NULL;
    var el_string = NULL;
    var rpm_spec_vers_cmp = NULL;
    var epoch = NULL;
    var allowmaj = NULL;
    var exists_check = NULL;
    var cves = NULL;
    if (!empty_or_null(pkg['reference'])) reference = pkg['reference'];
    if (!empty_or_null(pkg['release'])) _release = 'RHEL' + pkg['release'];
    if (!empty_or_null(pkg['sp'])) sp = pkg['sp'];
    if (!empty_or_null(pkg['cpu'])) _cpu = pkg['cpu'];
    if (!empty_or_null(pkg['el_string'])) el_string = pkg['el_string'];
    if (!empty_or_null(pkg['rpm_spec_vers_cmp'])) rpm_spec_vers_cmp = pkg['rpm_spec_vers_cmp'];
    if (!empty_or_null(pkg['epoch'])) epoch = pkg['epoch'];
    if (!empty_or_null(pkg['allowmaj'])) allowmaj = pkg['allowmaj'];
    if (!empty_or_null(pkg['exists_check'])) exists_check = pkg['exists_check'];
    if (!empty_or_null(pkg['cves'])) cves = pkg['cves'];
    if (reference &&
        _release &&
        rhel_decide_repo_relative_url_check(required_repo_url_list:repo_relative_urls) &&
        (applicable_repo_urls || (!exists_check || rpm_exists(release:_release, rpm:exists_check))) &&
        rpm_check(release:_release, sp:sp, cpu:_cpu, reference:reference, epoch:epoch, el_string:el_string, rpm_spec_vers_cmp:rpm_spec_vers_cmp, allowmaj:allowmaj, cves:cves)) flag++;
  }
}

if (flag)
{
  var extra = NULL;
  if (isnull(applicable_repo_urls) || !applicable_repo_urls) extra = rpm_report_get() + redhat_report_repo_caveat();
  else extra = rpm_report_get();
  security_report_v4(
      port       : 0,
      severity   : SECURITY_WARNING,
      extra      : extra
  );
  exit(0);
}
else
{
  var tested = pkg_tests_get();
  if (tested) audit(AUDIT_PACKAGE_NOT_AFFECTED, tested);
  else audit(AUDIT_PACKAGE_NOT_INSTALLED, 'bpftool / kernel / kernel-core / kernel-cross-headers / etc');
}
VendorProductVersionCPE
redhatenterprise_linux8cpe:/o:redhat:enterprise_linux:8
redhatrhel_eus8.6cpe:/o:redhat:rhel_eus:8.6
redhatenterprise_linuxbpftoolp-cpe:/a:redhat:enterprise_linux:bpftool
redhatenterprise_linuxkernelp-cpe:/a:redhat:enterprise_linux:kernel
redhatenterprise_linuxkernel-corep-cpe:/a:redhat:enterprise_linux:kernel-core
redhatenterprise_linuxkernel-cross-headersp-cpe:/a:redhat:enterprise_linux:kernel-cross-headers
redhatenterprise_linuxkernel-debugp-cpe:/a:redhat:enterprise_linux:kernel-debug
redhatenterprise_linuxkernel-debug-corep-cpe:/a:redhat:enterprise_linux:kernel-debug-core
redhatenterprise_linuxkernel-debug-develp-cpe:/a:redhat:enterprise_linux:kernel-debug-devel
redhatenterprise_linuxkernel-debug-modulesp-cpe:/a:redhat:enterprise_linux:kernel-debug-modules
Rows per page:
1-10 of 251