Qt 6.8.x < 6.8.10 / 6.9.0 < 6.11.3 Multiple Vulnerabilities
| Reporter | Title | Published | Views | Family All 47 |
|---|---|---|---|---|
| CVE-2026-105923 | 21 Oct 202617:11 | – | circl | |
| CVE-2026-105946 | 28 Oct 202609:15 | – | circl | |
| CVE-2026-96432 | 26 Oct 202611:42 | – | circl | |
| Improper Qt exception handling vulnerability | 26 Oct 202600:00 | – | cnnvd | |
| Qt numeric error vulnerability | 20 Oct 202616:00 | – | cnnvd | |
| Qt buffer error vulnerability | 27 Oct 202600:00 | – | cnnvd | |
| CVE-2026-105923 | 21 Oct 202609:21 | – | cve | |
| CVE-2026-105946 | 27 Oct 202606:45 | – | cve | |
| CVE-2026-96432 | 26 Oct 202611:31 | – | cve | |
| CVE-2026-105923 Null-pointer dereference in QTriangulator reachable through VectorImage | 21 Oct 202609:21 | – | cvelist |
10
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(374146);
script_version("1.2");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/02");
script_cve_id("CVE-2026-96432", "CVE-2026-105923", "CVE-2026-105946");
script_xref(name:"IAVA", value:"2026-A-1217");
script_name(english:"Qt 6.8.x < 6.8.10 / 6.9.0 < 6.11.3 Multiple Vulnerabilities");
script_set_attribute(attribute:"synopsis", value:
"The remote host has an application framework installed that is affected by multiple vulnerabilities.");
script_set_attribute(attribute:"description", value:
"The version of Qt installed on the remote host is 6.8.x prior to 6.8.10, or 6.9.0 or later prior to 6.11.3.
It is, therefore, affected by multiple vulnerabilities:
- A malicious or compromised HTTP/2 server withholding SETTINGS ACK can send RST_STREAM on a completed
stream, planting a null pointer, and then send a PUSH_PROMISE for that stream, causing a null pointer
dereference in the QNetworkAccessManager class of the Qt Network module that crashes the application.
(CVE-2026-96432)
- A malicious SVG can trigger an integer overflow which in turn triggers a null-pointer dereference in
VectorImage QML Type. (CVE-2026-105923)
- Out-of-bounds read in the QAuthenticator NTLM authentication handling in the Qt Network module in Qt
Group Qt allows remote attackers to obtain sensitive information (heap memory contents) or cause a denial
of service (application crash) via a crafted NTLM challenge sent by a malicious server or proxy, when an
application using QNetworkAccessManager or QTcpSocket authenticates with NTLM. (CVE-2026-105946)
Note that Nessus has not tested for these issues but has instead relied only on the application's
self-reported version number.");
script_set_attribute(attribute:"see_also", value:"https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products");
script_set_attribute(attribute:"solution", value:
"Upgrade Qt to version 6.8.10, 6.11.3, or later.");
script_set_attribute(attribute:"agent", value:"unix");
script_set_cvss_base_vector("CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:P");
script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H");
script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
script_set_attribute(attribute:"cvss4_vector", value:"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N");
script_set_attribute(attribute:"cvss4_supplemental", value:"CVSS:4.0/AU:N/R:U/RE:L/U:Green");
script_set_attribute(attribute:"cvss4_threat_vector", value:"CVSS:4.0/E:U");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-105946");
script_set_attribute(attribute:"cvss4_score_source", value:"CVE-2026-105923");
script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
script_set_attribute(attribute:"exploit_available", value:"false");
script_set_attribute(attribute:"vuln_publication_date", value:"2026/10/21");
script_set_attribute(attribute:"patch_publication_date", value:"2026/10/26");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/30");
script_set_attribute(attribute:"plugin_type", value:"local");
script_set_attribute(attribute:"asset_categories", value:"component");
script_set_attribute(attribute:"cpe", value:"cpe:/a:qt:qt");
script_set_attribute(attribute:"stig_severity", value:"I");
script_set_attribute(attribute:"thorough_tests", value:"true");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"Misc.");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("qt_nix_installed.nbin");
script_require_keys("installed_sw/Qt");
exit(0);
}
include('vdf.inc');
# @tvdl-content
var vuln_data = {
'metadata': {'spec_version': '1.0'},
'checks': [
{
'product': {'name': 'Qt', 'type': 'app'},
'check_algorithm': 'default',
'constraints': [
{'min_version': '6.8.0', 'fixed_version': '6.8.10'},
{'min_version': '6.9.0', 'fixed_version': '6.11.3'}
]
}
]
};
var res = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_WARNING);
vdf::handle_check_and_report_errors(vdf_result:res);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
02 Nov 2026 00:00Current
5.9Medium risk
Vulners AI Score5.9
CVSS 46.7
EPSS0.00455
SSVC