PHP 5.5.x < 5.5.8 Multiple Vulnerabilities

2014-01-13T00:00:00
ID PHP_5_5_8.NASL
Type nessus
Reporter Tenable
Modified 2018-02-20T00:00:00

Description

According to its banner, the version of PHP 5.5.x installed on the remote host is a version prior to 5.5.8. It is, therefore, potentially affected by the following vulnerabilities :

  • A heap-based buffer overflow error exists in the file 'ext/date/lib/parse_iso_intervals.c' related to handling DateInterval objects that could allow denial of service attacks. (CVE-2013-6712)

  • An integer overflow error exists in the function 'exif_process_IFD_TAG' in the file 'ext/exif/exif.c' that could allow denial of service attacks or arbitrary memory reads. (Bug #65873)

  • A use-after-free error exists in the function 'do_soap_call' in the file 'ext/soap/soap.c' related to 'typemap' values and error handling and having unspecified impact. (Bug #66112)

Note that this plugin does not attempt to exploit the vulnerabilities, but instead relies only on PHP's self-reported version number.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include("compat.inc");

if (description)
{
  script_id(71928);
  script_version("$Revision: 1.5 $");
  script_cvs_date("$Date: 2018/02/20 17:48:25 $");

  script_cve_id("CVE-2013-6712");
  script_bugtraq_id(64018);
  script_osvdb_id(100440);

  script_name(english:"PHP 5.5.x < 5.5.8 Multiple Vulnerabilities");
  script_summary(english:"Checks version of PHP");

  script_set_attribute(
    attribute:"synopsis",
    value:
"The remote web server uses a version of PHP that is potentially
affected by multiple vulnerabilities."
  );
  script_set_attribute(
    attribute:"description",
    value:
"According to its banner, the version of PHP 5.5.x installed on the
remote host is a version prior to 5.5.8.  It is, therefore, potentially
affected by the following vulnerabilities :

  - A heap-based buffer overflow error exists in the file
    'ext/date/lib/parse_iso_intervals.c' related to
    handling DateInterval objects that could allow denial
    of service attacks. (CVE-2013-6712)

  - An integer overflow error exists in the function
    'exif_process_IFD_TAG' in the file 'ext/exif/exif.c'
    that could allow denial of service attacks or arbitrary
    memory reads. (Bug #65873)

  - A use-after-free error exists in the function
    'do_soap_call' in the file 'ext/soap/soap.c' related
    to 'typemap' values and error handling and having
    unspecified impact. (Bug #66112)

Note that this plugin does not attempt to exploit the vulnerabilities,
but instead relies only on PHP's self-reported version number."
  );
  script_set_attribute(attribute:"see_also", value:"http://www.php.net/ChangeLog-5.php#5.5.8");
  script_set_attribute(attribute:"solution", value:"Upgrade to PHP version 5.5.8 or later.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2013/11/27");
  script_set_attribute(attribute:"patch_publication_date", value:"2014/01/09");
  script_set_attribute(attribute:"plugin_publication_date", value:"2014/01/13");

  script_set_attribute(attribute:"plugin_type", value:"remote");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:php:php");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2014-2018 Tenable Network Security, Inc.");

  script_dependencies("php_version.nasl");
  script_require_ports("Services/www", 80);
  script_require_keys("www/PHP");
  exit(0);
}

include("audit.inc");
include("global_settings.inc");
include("misc_func.inc");
include("http.inc");
include("webapp_func.inc");

port = get_http_port(default:80, php:TRUE);

php = get_php_from_kb(
  port : port,
  exit_on_fail : TRUE
);

version = php["ver"];
source = php["src"];

backported = get_kb_item('www/php/'+port+'/'+version+'/backported');

if (report_paranoia < 2 && backported) audit(AUDIT_BACKPORT_SERVICE, port, "PHP "+version+" install");

# Check that it is the correct version of PHP
if (version =~ "^5(\.5)?$") audit(AUDIT_VER_NOT_GRANULAR, "PHP", port, version);
if (version !~ "^5\.5\.") audit(AUDIT_NOT_DETECT, "PHP version 5.5.x", port);

if (version =~ "^5\.5\.[0-7]($|[^0-9])")
{
  if (report_verbosity > 0)
  {
    report =
      '\n  Version source    : '+source +
      '\n  Installed version : '+version+
      '\n  Fixed version     : 5.5.8\n';
    security_warning(port:port, extra:report);
  }
  else security_warning(port);
  exit(0);
}
else audit(AUDIT_LISTEN_NOT_VULN, "PHP", port, version);