Lucene search
+L

Palo Alto Networks PAN-OS 11.2.x / 12.1.x / 12.2.x Vulnerability

🗓️ 26 Oct 2026 00:00:00Reported by TenableType 
nessus
 nessus
🔗 www.tenable.com👁 2 Views

Remote unauthenticated buffer overflow in Brotli decoder on PAN-OS allows DoS or RCE.

Related
Refs
Code
ReporterTitlePublishedViews
Family
githubexploit
GithubExploit
Exploit for CVE-2026-111497
26 Oct 202613:10
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
24 Oct 202622:05
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
25 Oct 202604:22
–githubexploit
githubexploit
GithubExploit
cve-feed
28 Oct 202619:42
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
22 Oct 202608:52
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
24 Oct 202610:02
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
22 Oct 202604:08
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
25 Oct 202609:36
–githubexploit
githubexploit
GithubExploit
Exploit for Unchecked Return Value in Google Brotli
28 Oct 202622:44
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
27 Oct 202618:11
–githubexploit
Rows per page
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##

include('compat.inc');

if (description)
{
  script_id(372075);
  script_version("1.2");
  script_set_attribute(attribute:"plugin_modification_date", value:"2026/10/27");

  script_cve_id("CVE-2026-111497");
  script_xref(name:"CISA-KNOWN-EXPLOITED", value:"2026/11/10");

  script_name(english:"Palo Alto Networks PAN-OS 11.2.x / 12.1.x / 12.2.x Vulnerability");

  script_set_attribute(attribute:"synopsis", value:
"The remote PAN-OS host is affected by a vulnerability");
  script_set_attribute(attribute:"description", value:
"The version of Palo Alto Networks PAN-OS running on the remote host is a vulnerable version of 11.2.x, 12.1.x, or
12.2.x. It is, therefore, affected by a vulnerability.

    Palo Alto Networks is aware of the vulnerability in Brotli: CVE-2026-111497.

    A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3
    through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state
    memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary
    code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries
    between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.Brotli is commonly
    used by many HTTP-based applications including Node.js.

    Palo Alto Networks is actively investigating its product portfolio and cloud services to determine
    potential impact from this vulnerability. The sections below will be updated as our analysis progresses
    and additional information or remediation status becomes available.

Tenable has extracted the preceding description block directly from the PAN-OS security advisory.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
  script_set_attribute(attribute:"see_also", value:"https://security.paloaltonetworks.com/CVE-2026-xxyyzz");
  script_set_attribute(attribute:"solution", value:
"Upgrade to a fixed version");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P");
  script_set_cvss_temporal_vector("CVSS2#E:F/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:F/RL:O/RC:C");
  script_set_attribute(attribute:"cvss4_vector", value:"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N");
  script_set_attribute(attribute:"cvss4_threat_vector", value:"CVSS:4.0/E:A");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-111497");

  script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"true");
  script_cwe_id(787);

  script_set_attribute(attribute:"vuln_publication_date", value:"2026/10/21");
  script_set_attribute(attribute:"patch_publication_date", value:"2026/10/26");
  script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/26");

  script_set_attribute(attribute:"potential_vulnerability", value:"true");
  script_set_attribute(attribute:"plugin_type", value:"combined");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:paloaltonetworks:pan-os");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"Palo Alto Local Security Checks");

  script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("palo_alto_version.nbin");
  script_require_keys("Host/Palo_Alto/Firewall/Version", "Host/Palo_Alto/Firewall/Full_Version", "Host/Palo_Alto/Firewall/Source", "Settings/ParanoidReport");

  exit(0);
}

include('vcf.inc');
include('vcf_extras.inc');

vcf::palo_alto::initialize();

var app_name = 'Palo Alto Networks PAN-OS';

var app_info = vcf::get_app_info(app:app_name, kb_ver:'Host/Palo_Alto/Firewall/Full_Version', kb_source:'Host/Palo_Alto/Firewall/Source');

if (report_paranoia < 2) audit(AUDIT_PARANOID);

var constraints = [
  { 'min_version' : '11.2.4', 'fixed_version' : '11.2.4-h23' },
  { 'min_version' : '11.2.7', 'fixed_version' : '11.2.7-h23' },
  { 'min_version' : '11.2.10', 'fixed_version' : '11.2.10-h17' },
  { 'min_version' : '11.2.13', 'fixed_version' : '11.2.13-h4' },
  { 'min_version' : '11.2.16', 'fixed_version' : '11.2.16-h1' },
  { 'min_version' : '12.1.4', 'fixed_version' : '12.1.4-h13' },
  { 'min_version' : '12.1.7', 'fixed_version' : '12.1.7-h11' },
  { 'min_version' : '12.1.10', 'fixed_version' : '12.1.10-h3' },
  { 'min_version' : '12.2.0', 'fixed_version' : '12.2.4-h1' }
];

vcf::check_version_and_report(
    app_info:app_info,
    constraints:constraints,
    severity:SECURITY_HOLE
);

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

27 Oct 2026 00:00Current
8.1High risk
Vulners AI Score8.1
CVSS 3.19.8
CVSS 49.2
EPSS0.82641
SSVC
2