OpenJDK 8 <= 8u372 / 11.0.0 <= 11.0.19 / 17.0.0 <= 17.0.7 / 20.0.0 <= 20.0.1 Multiple Vulnerabilities (2023-07-18)
10
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(375882);
script_version("1.2");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/05");
script_cve_id(
"CVE-2023-22006",
"CVE-2023-22036",
"CVE-2023-22041",
"CVE-2023-22044",
"CVE-2023-22045",
"CVE-2023-22049",
"CVE-2023-25193"
);
script_name(english:"OpenJDK 8 <= 8u372 / 11.0.0 <= 11.0.19 / 17.0.0 <= 17.0.7 / 20.0.0 <= 20.0.1 Multiple Vulnerabilities (2023-07-18)");
script_set_attribute(attribute:"synopsis", value:
"OpenJDK is affected by multiple vulnerabilities.");
script_set_attribute(attribute:"description", value:
"The version of OpenJDK installed on the remote host is 8 prior to or at 8u372 / 11.0.0 prior to or at 11.0.20 / 17.0.0
prior to or at 17.0.8 / 20.0.0 prior to or at 20.0.2. It is, therefore, affected by multiple vulnerabilities as referenced
in the 2023-07-18 advisory.
Please Note: Java CVEs do not always include OpenJDK versions, but are confirmed separately by Tenable using the patch
versions from the referenced OpenJDK security advisory.
- Vulnerability in the Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM for JDK product of
Oracle Java SE (component: Hotspot). Difficult to exploit vulnerability allows unauthenticated attacker
with logon to the infrastructure where Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM
for JDK executes to compromise Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM for JDK.
Successful attacks of this vulnerability can result in unauthorized access to critical data or complete
access to all Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM for JDK accessible data.
Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web
Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from
the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java
deployments, typically in servers, that load and run only trusted code (e.g., code installed by an
administrator). (CVE-2023-22041)
- hb-ot-layout-gsubgpos.hh in HarfBuzz through 6.0.0 allows attackers to trigger O(n^2) growth via
consecutive marks during the process of looking back for base glyphs when attaching marks.
(CVE-2023-25193)
- Vulnerability in the Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM for JDK product of
Oracle Java SE (component: Networking). Difficult to exploit vulnerability allows unauthenticated attacker
with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM Enterprise Edition,
Oracle GraalVM for JDK. Successful attacks require human interaction from a person other than the attacker.
Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some
of Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM for JDK accessible data. Note: This
vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start
applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the
internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments,
typically in servers, that load and run only trusted code (e.g., code installed by an administrator).
(CVE-2023-22006)
Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version
number.");
script_set_attribute(attribute:"see_also", value:"https://openjdk.org/groups/vulnerability/advisories/2023-07-18");
script_set_attribute(attribute:"solution", value:
"Upgrade to an OpenJDK version greater than 8u372 / 11.0.19 / 17.0.7 / 20.0.1");
script_set_attribute(attribute:"agent", value:"all");
script_set_cvss_base_vector("CVSS2#AV:L/AC:H/Au:N/C:C/I:N/A:N");
script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
script_set_cvss3_base_vector("CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N");
script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2023-22041");
script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
script_set_attribute(attribute:"exploit_available", value:"false");
script_set_attribute(attribute:"vuln_publication_date", value:"2023/07/18");
script_set_attribute(attribute:"patch_publication_date", value:"2023/07/18");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/11/04");
script_set_attribute(attribute:"plugin_type", value:"local");
script_set_attribute(attribute:"cpe", value:"cpe:/a:oracle:openjdk");
script_set_attribute(attribute:"generated_plugin", value:"current");
script_set_attribute(attribute:"thorough_tests", value:"true");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"Misc.");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("adoptopenjdk_nix_installed.nbin", "adoptopenjdk_win_installed.nbin", "openjdk_win_installed.nbin", "openjdk_nix_installed.nbin", "temurin_java_nix_installed.nbin", "temurin_java_win_installed.nbin");
script_require_keys("installed_sw/Java");
exit(0);
}
include('vdf.inc');
# @tvdl-content
var vuln_data = {
"metadata": {
"spec_version": "1.0"
},
"checks": [
{
"product": {
"name": "Java",
"type": "app"
},
"check_algorithm": "default",
"requires": [
{
"scope": "install",
"match_one": {
"Application": [
"OpenJDK Java",
"AdoptOpenJDK",
"Temurin Java"
]
}
}
],
"constraints": [
{
"min_version": "8.0.0",
"max_version": "8.0.372",
"fixed_display": "Upgrade to a version greater than 8u372"
},
{
"min_version": "11.0.0",
"max_version": "11.0.19",
"fixed_display": "Upgrade to a version greater than 11.0.19"
},
{
"min_version": "17.0.0",
"max_version": "17.0.7",
"fixed_display": "Upgrade to a version greater than 17.0.7"
},
{
"min_version": "20.0.0",
"max_version": "20.0.1",
"fixed_display": "Upgrade to a version greater than 20.0.1"
}
]
}
]
};
var vdf_result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_WARNING);
vdf::handle_check_and_report_errors(vdf_result:vdf_result);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
05 Nov 2026 00:00Current
5.7Medium risk
Vulners AI Score5.7
CVSS 3.15.1 - 7.5
EPSS0.01812
SSVC