NetScaler ADC and NetScaler Gateway Multiple Vulnerabilities (CTX697263)
| Reporter | Title | Published | Views | Family All 956 |
|---|---|---|---|---|
| Exploit for CVE-2026-109618 | 21 Oct 202613:53 | – | githubexploit | |
| Exploit for CVE-2026-109618 | 21 Oct 202614:08 | – | githubexploit | |
| Exploit for Improperly Controlled Sequential Memory Allocation in Php | 22 Oct 202613:47 | – | githubexploit | |
| php2shell-assessment-global | 21 Oct 202613:31 | – | githubexploit | |
| Exploit for CVE-2026-109619 | 21 Oct 202617:42 | – | githubexploit | |
| Exploit for Improperly Controlled Sequential Memory Allocation in Php | 22 Oct 202610:01 | – | githubexploit | |
| Exploit for Improperly Controlled Sequential Memory Allocation in Php | 22 Oct 202609:21 | – | githubexploit | |
| Exploit for CVE-2026-109618 | 21 Oct 202614:36 | – | githubexploit | |
| Exploit for CVE-2026-109618 | 21 Oct 202613:19 | – | githubexploit | |
| php2shell-detect-exploit-kit | 21 Oct 202615:13 | – | githubexploit |
10
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(373228);
script_version("1.2");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/10/29");
script_cve_id("CVE-2026-109618", "CVE-2026-109619");
script_name(english:"NetScaler ADC and NetScaler Gateway Multiple Vulnerabilities (CTX697263)");
script_set_attribute(attribute:"synopsis", value:
"The remote device is affected by multiple vulnerabilities.");
script_set_attribute(attribute:"description", value:
"The remote NetScaler ADC (formerly Citrix ADC) or NetScaler Gateway (formerly Citrix Gateway) device is
13.1 prior to 13.1-64.32, or 14.1 prior to 14.1-73.49, or 13.1-FIPS/NDcPP prior to 13.1-37.286, or 14.1-FIPS
prior to 14.1-73.49-FIPS. It is, therefore, affected by multiple vulnerabilities in its embedded PHP
component, as referenced in the CTX697263 advisory.
- Remote code execution vulnerability in PHP due to out-of-memory corruption. An unauthenticated remote
attacker can exploit this to execute arbitrary code. (CVE-2026-109618)
- Remote code execution vulnerability in PHP due to stale global state. An unauthenticated remote attacker
can exploit this to execute arbitrary code. (CVE-2026-109619)
Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported
version number.");
# https://support.citrix.com/external/article/CTX697263/citrix-security-advisory-for-cve20261096.html
script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?413c4dda");
script_set_attribute(attribute:"solution", value:
"Upgrade to NetScaler ADC or NetScaler Gateway version 13.1-64.32, 14.1-73.49, 13.1-37.286-FIPS,
13.1-37.286-NDcPP, or 14.1-73.49-FIPS or later.");
script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C");
script_set_cvss_temporal_vector("CVSS2#E:H/RL:OF/RC:C");
script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H");
script_set_cvss3_temporal_vector("CVSS:3.0/E:H/RL:O/RC:C");
script_set_attribute(attribute:"cvss4_vector", value:"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N");
script_set_attribute(attribute:"cvss4_threat_vector", value:"CVSS:4.0/E:A");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-109618");
script_set_attribute(attribute:"cvss4_score_source", value:"CVE-2026-109619");
script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
script_set_attribute(attribute:"exploit_available", value:"true");
script_set_attribute(attribute:"exploited_by_malware", value:"true");
script_cwe_id(416, 755, 824, 1325, 1419);
script_set_attribute(attribute:"vuln_publication_date", value:"2026/10/21");
script_set_attribute(attribute:"patch_publication_date", value:"2026/10/27");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/28");
script_set_attribute(attribute:"plugin_type", value:"combined");
script_set_attribute(attribute:"cpe", value:"cpe:/h:citrix:netscaler_gateway");
script_set_attribute(attribute:"cpe", value:"cpe:/h:citrix:netscaler_application_delivery_controller");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"CGI abuses");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("citrix_netscaler_detect.nbin");
script_require_keys("Host/NetScaler/Detected");
exit(0);
}
include('vcf_extras_netscaler.inc');
var app_info = vcf::citrix_netscaler::get_app_info();
var constraints;
if (app_info['fips_status'] == 1)
constraints = [
{'fips':TRUE, 'min_version': '13.1', 'fixed_version': '13.1.37.286', 'fixed_display': '13.1-37.286-FIPS/NDcPP'},
{'fips':TRUE, 'min_version': '14.1', 'fixed_version': '14.1.73.49', 'fixed_display': '14.1-73.49-FIPS'}
];
else
constraints = [
{'min_version': '13.1', 'fixed_version': '13.1.64.32', 'fixed_display': '13.1-64.32'},
{'min_version': '14.1', 'fixed_version': '14.1.73.49', 'fixed_display': '14.1-73.49'}
];
vcf::citrix_netscaler::check_version_and_report(
app_info:app_info,
constraints:constraints,
severity:SECURITY_HOLE
);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
29 Oct 2026 00:00Current
9.8Critical risk
Vulners AI Score9.8
CVSS 3.19.8
CVSS 49.2
EPSS0.99999
SSVC