Mozilla Firefox ESR < 52.7.2 Multiple Code Execution Vulnerabilities

2018-03-23T00:00:00
ID MOZILLA_FIREFOX_52_7_2_ESR.NASL
Type nessus
Reporter Tenable
Modified 2018-08-10T00:00:00

Description

The version of Mozilla Firefox ESR installed on the remote Windows host is prior to 52.7.2. It is, therefore, affected by multiple code execution vulnerabilities. A out-of-bounds write flaw exists in multiple functions of the codebook.c script when decoding Vorbis audio data. A context-dependent attacker could corrupt memory and potentially execute arbitrary code.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include("compat.inc");

if (description)
{
  script_id(108586);
  script_version("1.4");
  script_cvs_date("Date: 2018/08/10 18:07:08");

  script_cve_id("CVE-2018-5146", "CVE-2018-5147");
  script_bugtraq_id(103432);
  script_xref(name:"MFSA", value:"2018-08");

  script_name(english:"Mozilla Firefox ESR < 52.7.2 Multiple Code Execution Vulnerabilities");
  script_summary(english:"Checks the version of Firefox.");

  script_set_attribute(attribute:"synopsis", value:
"A web browser installed on the remote Windows host is affected by
multiple code execution vulnerabilities.");
  script_set_attribute(attribute:"description", value:
"The version of Mozilla Firefox ESR installed on the remote Windows
host is prior to 52.7.2. It is, therefore, affected by multiple code
execution vulnerabilities. A out-of-bounds write flaw exists in
multiple functions of the codebook.c script when decoding Vorbis audio
data. A context-dependent attacker could corrupt memory and potentially
execute arbitrary code.");
  script_set_attribute(attribute:"see_also", value:"https://www.mozilla.org/en-US/security/advisories/mfsa2018-08/");
  script_set_attribute(attribute:"solution", value:
"Upgrade to Mozilla Firefox ESR version 52.7.2 or later.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H");

  script_set_attribute(attribute:"vuln_publication_date", value:"2018/03/15");
  script_set_attribute(attribute:"patch_publication_date", value:"2018/03/16");
  script_set_attribute(attribute:"plugin_publication_date", value:"2018/03/23");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:mozilla:firefox_esr");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"Windows");

  script_copyright(english:"This script is Copyright (C) 2018 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("mozilla_org_installed.nasl");
  script_require_keys("Mozilla/Firefox/Version");

  exit(0);
}

include("mozilla_version.inc");

port = get_kb_item("SMB/transport");
if (!port) port = 445;

installs = get_kb_list("SMB/Mozilla/Firefox/*");
if (isnull(installs)) audit(AUDIT_NOT_INST, "Firefox");

mozilla_check_version(installs:installs, product:'firefox', esr:TRUE, fix:'52.7.2', min:'52', severity:SECURITY_HOLE);