Microsoft PowerShell 7.4.x < 7.4.22 / 7.5.x < 7.5.13 / 7.6.x < 7.6.9 RCE (macOS)
| Reporter | Title | Published | Views | Family All 999 |
|---|---|---|---|---|
| Exploit for CVE-2026-111497 | 26 Oct 202613:10 | – | githubexploit | |
| Exploit for CVE-2026-111497 | 24 Oct 202622:05 | – | githubexploit | |
| Exploit for CVE-2026-111497 | 25 Oct 202604:22 | – | githubexploit | |
| cve-feed | 28 Oct 202619:42 | – | githubexploit | |
| Exploit for CVE-2026-111497 | 22 Oct 202608:52 | – | githubexploit | |
| Exploit for CVE-2026-111497 | 24 Oct 202610:02 | – | githubexploit | |
| Exploit for CVE-2026-111497 | 22 Oct 202604:08 | – | githubexploit | |
| Exploit for CVE-2026-111497 | 25 Oct 202609:36 | – | githubexploit | |
| Exploit for Unchecked Return Value in Google Brotli | 28 Oct 202622:44 | – | githubexploit | |
| Exploit for CVE-2026-111497 | 27 Oct 202618:11 | – | githubexploit |
10
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(374268);
script_version("1.1");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/10/30");
script_cve_id("CVE-2026-111497");
script_xref(name:"IAVA", value:"2026-A-1202");
script_name(english:"Microsoft PowerShell 7.4.x < 7.4.22 / 7.5.x < 7.5.13 / 7.6.x < 7.6.9 RCE (macOS)");
script_set_attribute(attribute:"synopsis", value:
"The Microsoft PowerShell install on the remote macOS host is affected by a remote code execution vulnerability.");
script_set_attribute(attribute:"description", value:
"The version of Microsoft PowerShell installed on the remote macOS host is 7.4.x prior to 7.4.22, 7.5.x prior to
7.5.13, or 7.6.x prior to 7.6.9. It is, therefore, affected by a remote code execution vulnerability. An out-of-bounds
write in the Brotli decoder used by PowerShell 7 allows an unauthorized attacker to elevate privileges over a network.
The issue affects use of Invoke-WebRequest or Invoke-RestMethod against websites without SSL or that the user does not
control.
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
# https://github.com/PowerShell/Announcements/blob/main/pwsh/2026/10/CVE-2026-111497.md
script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?fda06208");
script_set_attribute(attribute:"see_also", value:"https://msrc.microsoft.com/update-guide/vulnerability/CVE-2026-111497");
script_set_attribute(attribute:"solution", value:
"Upgrade to Microsoft PowerShell version 7.4.22, 7.5.13, 7.6.9, or later.");
script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C");
script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H");
script_set_attribute(attribute:"cvss4_vector", value:"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-111497");
script_cwe_id(252, 787);
script_set_attribute(attribute:"vuln_publication_date", value:"2026/10/21");
script_set_attribute(attribute:"patch_publication_date", value:"2026/10/25");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/30");
script_set_attribute(attribute:"plugin_type", value:"local");
script_set_attribute(attribute:"cpe", value:"cpe:/a:microsoft:powershell");
script_set_attribute(attribute:"cpe", value:"cpe:/o:apple:mac_os_x");
script_set_attribute(attribute:"stig_severity", value:"I");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"MacOS X Local Security Checks");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("microsoft_powershell_macos_installed.nbin");
script_require_keys("installed_sw/PowerShell", "Host/MacOSX/Version");
exit(0);
}
include('vdf.inc');
# @tvdl-content
var vuln_data = {
'metadata': {'spec_version': '1.0'},
'requires': [
{'scope': 'target', 'match': {'os': 'macos'}}
],
'checks': [
{
'product': {'name': 'PowerShell', 'type': 'app'},
'check_algorithm': 'default',
'constraints': [
{'min_version': '7.4.0', 'fixed_version': '7.4.22'},
{'min_version': '7.5.0', 'fixed_version': '7.5.13'},
{'min_version': '7.6.0', 'fixed_version': '7.6.9'}
]
}
]
};
var result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_HOLE);
vdf::handle_check_and_report_errors(vdf_result:result);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
30 Oct 2026 00:00Current
7.9High risk
Vulners AI Score7.9
CVSS 3.19.8
CVSS 49.2
EPSS0.82641
SSVC