Logstash 8.12.1 < 8.19.24 / 9.0.x < 9.4.9 / 9.5.x < 9.5.6 Multiple Vulnerabilities (ESA-2026-228)
10
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(375648);
script_version("1.2");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/04");
script_cve_id("CVE-2026-114820", "CVE-2026-91403");
script_name(english:"Logstash 8.12.1 < 8.19.24 / 9.0.x < 9.4.9 / 9.5.x < 9.5.6 Multiple Vulnerabilities (ESA-2026-228)");
script_set_attribute(attribute:"synopsis", value:
"The remote host is affected by multiple vulnerabilities.");
script_set_attribute(attribute:"description", value:
"The version of Logstash installed on the remote host is 8.12.1 or later prior to 8.19.24, or 9.0.x prior to 9.4.9, or
9.5.x prior to 9.5.6. It is, therefore, affected by multiple vulnerabilities as referenced in the ESA-2026-228 advisory.
- Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of
Oracle Java SE (component: JSSE). Supported versions that are affected are Oracle Java SE: 8u511,
8u511-perf, 11.0.33, 17.0.21, 21.0.13, 25.0.5, 27.0.1; Oracle GraalVM for JDK: 17.0.21 and 21.0.13; Oracle
GraalVM Enterprise Edition: 21.3.20. Easily exploitable vulnerability allows unauthenticated attacker with
network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM
Enterprise Edition. Successful attacks of this vulnerability can result in unauthorized creation, deletion
or modification access to critical data or all Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM
Enterprise Edition accessible data as well as unauthorized access to critical data or complete access to
all Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition accessible data. Note: This
vulnerability can be exploited by using APIs in the specified Component, e.g., through a web service which
supplies data to the APIs. This vulnerability also applies to Java deployments, typically in clients
running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code
(e.g., code that comes from the internet) and rely on the Java sandbox for security. (CVE-2026-91403)
- Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of
Oracle Java SE (component: JSSE). Supported versions that are affected are Oracle Java SE: 8u511-b32,
8u511-perf-b32, 11.0.33.0.2, 17.0.21.0.2, 21.0.13.0.2, 25.0.5.0.2, 27.0.1.0.2; Oracle GraalVM for JDK:
17.0.21.0.2 and 21.0.13.0.2; Oracle GraalVM Enterprise Edition: 21.3.20.0.2. Easily exploitable
vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise
Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition. Successful attacks of this
vulnerability can result in unauthorized creation, deletion or modification access to critical data or all
Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition accessible data as well as
unauthorized access to critical data or complete access to all Oracle Java SE, Oracle GraalVM for JDK,
Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability can be exploited by using APIs
in the specified Component, e.g., through a web service which supplies data to the APIs. This
vulnerability also applies to Java deployments, typically in clients running sandboxed Java Web Start
applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the
internet) and rely on the Java sandbox for security. (CVE-2026-114820)
Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version
number.");
script_set_attribute(attribute:"see_also", value:"https://discuss.elastic.co/t/391365");
script_set_attribute(attribute:"solution", value:
"Upgrade to Logstash version 8.19.24, 9.4.9, or 9.5.6 or later as appropriate for your release branch.");
script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N");
script_set_cvss_temporal_vector("CVSS2#E:POC/RL:OF/RC:C");
script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N");
script_set_cvss3_temporal_vector("CVSS:3.0/E:P/RL:O/RC:C");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-91403");
script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
script_set_attribute(attribute:"exploit_available", value:"true");
script_set_attribute(attribute:"vuln_publication_date", value:"2026/10/20");
script_set_attribute(attribute:"patch_publication_date", value:"2026/11/03");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/11/03");
script_set_attribute(attribute:"plugin_type", value:"remote");
script_set_attribute(attribute:"cpe", value:"cpe:/a:elasticsearch:logstash");
script_set_attribute(attribute:"generated_plugin", value:"current");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"CGI abuses");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("logstash_api_detect.nbin");
script_require_keys("installed_sw/Logstash");
script_require_ports("Services/www", 9600);
exit(0);
}
include('vcf.inc');
include('http.inc');
var app = 'Logstash';
get_install_count(app_name:app, exit_if_zero:TRUE);
var port = get_http_port(default:9600);
var app_info = vcf::get_app_info(app:app, port:port, webapp:TRUE);
var constraints = [
{ 'min_version' : '8.12.1', 'fixed_version' : '8.19.24' },
{ 'min_version' : '9.0.0', 'fixed_version' : '9.4.9' },
{ 'min_version' : '9.5.0', 'fixed_version' : '9.5.6' }
];
vcf::check_version_and_report(
app_info:app_info,
constraints:constraints,
severity:SECURITY_HOLE
);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
04 Nov 2026 00:00Current
5.8Medium risk
Vulners AI Score5.8
CVSS 3.19.1
EPSS0.00375
SSVC