Lucene search
+L

Kibana 8.x < 8.19.24 / 9.0.x < 9.4.9 / 9.5.x < 9.5.6 (ESA-2026-237)

🗓️ 03 Nov 2026 00:00:00Reported by TenableType 
nessus
 nessus
🔗 www.tenable.com👁 6 Views

Improper certificate validation in various Elastic products using OS certificate bundles.

Related
Refs
Code
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##

include('compat.inc');

if (description)
{
  script_id(375643);
  script_version("1.1");
  script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/03");

  script_cve_id("CVE-2026-115714");

  script_name(english:"Kibana 8.x < 8.19.24 / 9.0.x < 9.4.9 / 9.5.x < 9.5.6 (ESA-2026-237)");

  script_set_attribute(attribute:"synopsis", value:
"The remote host is affected by a vulnerability.");
  script_set_attribute(attribute:"description", value:
"The version of Kibana installed on the remote host is 8.x prior to 8.19.24, or 9.0.x prior to 9.4.9, or 9.5.x prior to
9.5.6. It is, therefore, affected by a vulnerability as referenced in the ESA-2026-237 advisory.

  - Improper Certificate Validation (CWE-295) in the operating system certificate bundle shipped in the Docker
    images of APM Server; Auditbeat, Filebeat, Heartbeat, Metricbeat and Packetbeat; Elastic Agent, including
    Fleet Server and Cloudbeat; Logstash, for TLS connections that use the operating system certificate
    bundle; Elastic connectors; Universal Profiling (host agent, collector and symbolizer); and Elastic Maps
    Server. This certificate bundle, a dependency of these products (Dependency on Vulnerable Third-Party
    Component, CWE-1395), could allow an attacker to intercept or modify TLS-protected traffic via Signature
    Spoofing by Key Theft (CAPEC-474). The certificate bundle includes root certificate authorities that
    signed eight eMudhra intermediate certificate authorities whose private keys are compromised. Anyone with
    these keys can issue a certificate for any host name that these products accept as trusted. Exploitation
    requires an attacker in a network position between the product and the remote party, who presents a
    certificate issued with one of the compromised keys. (CVE-2026-115714)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
  script_set_attribute(attribute:"see_also", value:"https://discuss.elastic.co/t/391374");
  script_set_attribute(attribute:"solution", value:
"Upgrade to Kibana version 8.19.24, 9.4.9, or 9.5.6 or later as appropriate for your release branch.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:N");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-115714");

  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2026/11/03");
  script_set_attribute(attribute:"patch_publication_date", value:"2026/11/03");
  script_set_attribute(attribute:"plugin_publication_date", value:"2026/11/03");

  script_set_attribute(attribute:"plugin_type", value:"remote");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:elasticsearch:kibana");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("kibana_web_detect.nbin");
  script_require_keys("installed_sw/Kibana");
  script_require_ports("Services/www", 5601);

  exit(0);
}

include('vcf.inc');
include('http.inc');

var app = 'Kibana';

get_install_count(app_name:app, exit_if_zero:TRUE);

var port = get_http_port(default:5601);

var app_info = vcf::get_app_info(app:app, port:port, webapp:TRUE);

var constraints = [
  { 'min_version' : '8.0.0', 'fixed_version' : '8.19.24' },
  { 'min_version' : '9.0.0', 'fixed_version' : '9.4.9' },
  { 'min_version' : '9.5.0', 'fixed_version' : '9.5.6' }
];

vcf::check_version_and_report(
    app_info:app_info,
    constraints:constraints,
    severity:SECURITY_HOLE
);

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation