Lucene search
+L

Kibana 8.x < 8.19.24 / 9.0.x < 9.4.9 / 9.5.x < 9.5.6 RCE (ESA-2026-232)

🗓️ 03 Nov 2026 00:00:00Reported by TenableType 
nessus
 nessus
🔗 www.tenable.com👁 4 Views

Remote unauthenticated RCE in Kibana via a buffer overflow in the Brotli decoder.

Related
Refs
Code
ReporterTitlePublishedViews
Family
githubexploit
GithubExploit
Exploit for CVE-2026-111497
26 Oct 202613:10
–githubexploit
githubexploit
GithubExploit
Exploit for Unchecked Return Value in Google Brotli
2 Nov 202608:55
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
24 Oct 202622:05
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
25 Oct 202604:22
–githubexploit
githubexploit
GithubExploit
cve-feed
28 Oct 202619:42
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
22 Oct 202608:52
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
24 Oct 202610:02
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
22 Oct 202604:08
–githubexploit
githubexploit
GithubExploit
Exploit for CVE-2026-111497
25 Oct 202609:36
–githubexploit
githubexploit
GithubExploit
Exploit for Unchecked Return Value in Google Brotli
28 Oct 202622:44
–githubexploit
Rows per page
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##

include('compat.inc');

if (description)
{
  script_id(375645);
  script_version("1.3");
  script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/05");

  script_cve_id("CVE-2026-111497");
  script_xref(name:"CISA-KNOWN-EXPLOITED", value:"2026/11/10");

  script_name(english:"Kibana 8.x < 8.19.24 / 9.0.x < 9.4.9 / 9.5.x < 9.5.6 RCE (ESA-2026-232)");

  script_set_attribute(attribute:"synopsis", value:
"The remote host is affected by a remote code execution vulnerability.");
  script_set_attribute(attribute:"description", value:
"The version of Kibana installed on the remote host is 8.x prior to 8.19.24, or 9.0.x prior to 9.4.9, or 9.5.x prior to
9.5.6. It is, therefore, affected by a vulnerability as referenced in the ESA-2026-232 advisory.

  - A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3
    through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state
    memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary
    code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries
    between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1. (CVE-2026-111497)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
  script_set_attribute(attribute:"see_also", value:"https://discuss.elastic.co/t/391369");
  script_set_attribute(attribute:"solution", value:
"Upgrade to Kibana version 8.19.24, 9.4.9, or 9.5.6 or later as appropriate for your release branch.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C");
  script_set_cvss_temporal_vector("CVSS2#E:H/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:H/RL:O/RC:C");
  script_set_attribute(attribute:"cvss4_vector", value:"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N");
  script_set_attribute(attribute:"cvss4_threat_vector", value:"CVSS:4.0/E:A");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-111497");

  script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"true");
  script_set_attribute(attribute:"exploited_by_malware", value:"true");

  script_set_attribute(attribute:"vuln_publication_date", value:"2026/10/21");
  script_set_attribute(attribute:"patch_publication_date", value:"2026/11/03");
  script_set_attribute(attribute:"plugin_publication_date", value:"2026/11/03");

  script_set_attribute(attribute:"plugin_type", value:"remote");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:elasticsearch:kibana");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("kibana_web_detect.nbin");
  script_require_keys("installed_sw/Kibana");
  script_require_ports("Services/www", 5601);

  exit(0);
}

include('vcf.inc');
include('http.inc');

var app = 'Kibana';

get_install_count(app_name:app, exit_if_zero:TRUE);

var port = get_http_port(default:5601);

var app_info = vcf::get_app_info(app:app, port:port, webapp:TRUE);

var constraints = [
  { 'min_version' : '8.0.0', 'fixed_version' : '8.19.24' },
  { 'min_version' : '9.0.0', 'fixed_version' : '9.4.9' },
  { 'min_version' : '9.5.0', 'fixed_version' : '9.5.6' }
];

vcf::check_version_and_report(
    app_info:app_info,
    constraints:constraints,
    severity:SECURITY_HOLE
);

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

05 Nov 2026 00:00Current
7.8High risk
Vulners AI Score7.8
CVSS 3.19.8
CVSS 49.2
EPSS0.82641
SSVC
4