Lucene search
+L

Kibana 8.x < 8.19.24 / 9.0.x < 9.4.9 / 9.5.x < 9.5.6 (ESA-2026-229)

🗓️ 03 Nov 2026 00:00:00Reported by TenableType 
nessus
 nessus
🔗 www.tenable.com👁 3 Views

Kibana is affected by weak intermediate CA certificates in the system CA store.

Related
Refs
Code
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##

include('compat.inc');

if (description)
{
  script_id(375654);
  script_version("1.2");
  script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/04");

  script_cve_id("CVE-2026-114406");

  script_name(english:"Kibana 8.x < 8.19.24 / 9.0.x < 9.4.9 / 9.5.x < 9.5.6 (ESA-2026-229)");

  script_set_attribute(attribute:"synopsis", value:
"The remote host is affected by a vulnerability.");
  script_set_attribute(attribute:"description", value:
"The version of Kibana installed on the remote host is 8.x prior to 8.19.24, or 9.0.x prior to 9.4.9, or 9.5.x prior to
9.5.6. It is, therefore, affected by a vulnerability as referenced in the ESA-2026-229 advisory.

  - The system certificate authority (CA) store in Red Hat products, distributed via ca-certificates RPM
    packages, included multiple root CA certificates of authorities, which signed intermediate CA certificates
    with weak private keys issued by the eMudhra certificate authority. A man-in-the-middle attacker could use
    this flaw to issue certificates for arbitrary host names signed by the weak intermediate CA certificates,
    which would be considered trusted by a TLS/SSL client using system CA store and cause such clients to
    connect to malicious sites. Due to inability to only distrust specific intermediate certificates in all
    clients using the system CA store, root CA certificates of authorities that signed weak intermediate CA
    certificates are being removed. (CVE-2026-114406)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
  script_set_attribute(attribute:"see_also", value:"https://discuss.elastic.co/t/391366");
  script_set_attribute(attribute:"solution", value:
"Upgrade to Kibana version 8.19.24, 9.4.9, or 9.5.6 or later as appropriate for your release branch.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:N");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-114406");

  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2026/10/21");
  script_set_attribute(attribute:"patch_publication_date", value:"2026/11/03");
  script_set_attribute(attribute:"plugin_publication_date", value:"2026/11/03");

  script_set_attribute(attribute:"plugin_type", value:"remote");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:elasticsearch:kibana");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("kibana_web_detect.nbin");
  script_require_keys("installed_sw/Kibana");
  script_require_ports("Services/www", 5601);

  exit(0);
}

include('vcf.inc');
include('http.inc');

var app = 'Kibana';

get_install_count(app_name:app, exit_if_zero:TRUE);

var port = get_http_port(default:5601);

var app_info = vcf::get_app_info(app:app, port:port, webapp:TRUE);

var constraints = [
  { 'min_version' : '8.0.0', 'fixed_version' : '8.19.24' },
  { 'min_version' : '9.0.0', 'fixed_version' : '9.4.9' },
  { 'min_version' : '9.5.0', 'fixed_version' : '9.5.6' }
];

vcf::check_version_and_report(
    app_info:app_info,
    constraints:constraints,
    severity:SECURITY_HOLE
);

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

04 Nov 2026 00:00Current
6.2Medium risk
Vulners AI Score6.2
CVSS 3.16.8
EPSS0.0031
SSVC
3