Kibana 9.3.x < 9.4.9 / 9.5.x < 9.5.6 Path Traversal (ESA-2026-205)
| Reporter | Title | Published | Views | Family All 9 |
|---|---|---|---|---|
| CVE-2026-115294 | 3 Nov 202616:56 | – | circl | |
| CVE-2026-115294 | 3 Nov 202616:44 | – | cve | |
| CVE-2026-115294 Improper Limitation of a Pathname to a Restricted Directory in Kibana Leading to Unauthorized Resource Deletion | 3 Nov 202616:44 | – | cvelist | |
| Kibana 9.4.9, 9.5.6 Security Update (ESA-2026-205) | 3 Nov 202616:28 | – | elastic | |
| EUVD-2026-116075 | 3 Nov 202616:44 | – | euvd | |
| CVE-2026-115294 | 3 Nov 202617:17 | – | nvd | |
| PT-2026-136279 | 3 Nov 202600:00 | – | ptsecurity | |
| CVE-2026-115294: Elastic Kibana: Improper Limitation of a Pathname to a Restricted Directory (CWE-22) in the Kibana Fleet feature can lead to… | 3 Nov 202600:00 | – | rapid7 | |
| CVE-2026-115294 Improper Limitation of a Pathname to a Restricted Directory in Kibana Leading to Unauthorized Resource Deletion | 3 Nov 202616:44 | – | vulnrichment |
| Source | Link |
|---|---|
| discuss | www.discuss.elastic.co/t/391359 |
| cve | www.cve.mitre.org/cgi-bin/cvename.cgi |
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(375653);
script_version("1.1");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/03");
script_cve_id("CVE-2026-115294");
script_name(english:"Kibana 9.3.x < 9.4.9 / 9.5.x < 9.5.6 Path Traversal (ESA-2026-205)");
script_set_attribute(attribute:"synopsis", value:
"The remote host is affected by a path traversal vulnerability.");
script_set_attribute(attribute:"description", value:
"The version of Kibana installed on the remote host is 9.3.x prior to 9.4.9, or 9.5.x prior to 9.5.6. It is, therefore,
affected by a vulnerability as referenced in the ESA-2026-205 advisory.
- Improper Limitation of a Pathname to a Restricted Directory (CWE-22) in the Kibana Fleet feature can lead
to unauthorized resource deletion via Path Traversal (CAPEC-126). A low-privileged user with Fleet agent
policies write access could cause a subsequent administrative action to act on unintended resources. This
can result in the deletion of resources such as Kibana spaces and other organizational assets that the
low-privileged user cannot delete directly. Exploitation requires an administrator to interact with the
affected Fleet interface. (CVE-2026-115294)
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
script_set_attribute(attribute:"see_also", value:"https://discuss.elastic.co/t/391359");
script_set_attribute(attribute:"solution", value:
"Upgrade to Kibana version 9.4.9, or 9.5.6 or later as appropriate for your release branch.");
script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:S/C:N/I:C/A:C");
script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:H");
script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-115294");
script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
script_set_attribute(attribute:"exploit_available", value:"false");
script_set_attribute(attribute:"vuln_publication_date", value:"2026/11/03");
script_set_attribute(attribute:"patch_publication_date", value:"2026/11/03");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/11/03");
script_set_attribute(attribute:"plugin_type", value:"remote");
script_set_attribute(attribute:"cpe", value:"cpe:/a:elasticsearch:kibana");
script_set_attribute(attribute:"generated_plugin", value:"current");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"CGI abuses");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("kibana_web_detect.nbin");
script_require_keys("installed_sw/Kibana");
script_require_ports("Services/www", 5601);
exit(0);
}
include('vcf.inc');
include('http.inc');
var app = 'Kibana';
get_install_count(app_name:app, exit_if_zero:TRUE);
var port = get_http_port(default:5601);
var app_info = vcf::get_app_info(app:app, port:port, webapp:TRUE);
var constraints = [
{ 'min_version' : '9.3.0', 'fixed_version' : '9.4.9' },
{ 'min_version' : '9.5.0', 'fixed_version' : '9.5.6' }
];
vcf::check_version_and_report(
app_info:app_info,
constraints:constraints,
severity:SECURITY_HOLE
);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
03 Nov 2026 00:00Current
5.9Medium risk
Vulners AI Score5.9
CVSS 3.17.3
EPSS0.00341
SSVC