Joomla! 1.5.0 < 3.8.2 Multiple Vulnerabilities

2017-11-09T00:00:00
ID JOOMLA_382.NASL
Type nessus
Reporter This script is Copyright (C) 2017-2019 and is owned by Tenable, Inc. or an Affiliate thereof.
Modified 2020-01-02T00:00:00

Description

According to its self-reported version number, the Joomla! installation running on the remote web server is 1.5.0 or later but prior to 3.8.2. It is, therefore, affected by an authentication bypass and multiple information disclosure vulnerabilities.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include("compat.inc");

if (description)
{
  script_id(104478);
  script_version("1.6");
  script_cvs_date("Date: 2019/11/12");

  script_cve_id("CVE-2017-14596", "CVE-2017-16633", "CVE-2017-16634");
  script_bugtraq_id(101701, 101702);

  script_name(english:"Joomla! 1.5.0 < 3.8.2 Multiple Vulnerabilities");
  script_summary(english:"Checks the version of Joomla!.");

  script_set_attribute(attribute:"synopsis", value:
"The remote web server contains a PHP application that is affected by
multiple vulnerabilities.");
  script_set_attribute(attribute:"description", value:
"According to its self-reported version number, the Joomla!
installation running on the remote web server is 1.5.0 or later but
prior to 3.8.2. It is, therefore, affected by an authentication bypass
and multiple information disclosure vulnerabilities.

Note that Nessus has not attempted to exploit these issues but has
instead relied only on the application's self-reported version number.");
  # https://developer.joomla.org/security-centre/714-20171101-core-ldap-information-disclosure.html
  script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?0bfe3781");
  # https://developer.joomla.org/security-centre/713-20171102-core-2-factor-authentication-bypass.html
  script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?44542f6b");
  # https://developer.joomla.org/security-centre/715-20171103-core-information-disclosure.html
  script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?d551f20d");
  # https://www.joomla.org/announcements/release-news/5716-joomla-3-8-2-release.html
  script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?80b9ab84");
  script_set_attribute(attribute:"solution", value:
"Upgrade to Joomla! version 3.8.2 or later.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P");
  script_set_cvss_temporal_vector("CVSS2#E:F/RL:OF/RC:ND");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:F/RL:O/RC:X");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2017-16634");

  script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"true");

  script_set_attribute(attribute:"vuln_publication_date", value:"2017/11/07");
  script_set_attribute(attribute:"patch_publication_date", value:"2017/11/07");
  script_set_attribute(attribute:"plugin_publication_date", value:"2017/11/09");

  script_set_attribute(attribute:"plugin_type", value:"remote");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:joomla:joomla\!");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2017-2019 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("joomla_detect.nasl");
  script_require_keys("installed_sw/Joomla!", "www/PHP", "Settings/ParanoidReport");
  script_require_ports("Services/www", 80);

  exit(0);
}

include("http.inc");
include("vcf.inc");

port = get_http_port(default:80, php:TRUE);

if (report_paranoia < 2) audit(AUDIT_PARANOID);

app_info = vcf::get_app_info(app:"Joomla!", port:port, webapp:TRUE);

vcf::check_granularity(app_info:app_info, sig_segments:3);

constraints = [
  { "min_version" : "1.5.0", "fixed_version" : "3.8.2" }
];

vcf::check_version_and_report(app_info:app_info, constraints:constraints, severity:SECURITY_HOLE);