IBM MQ 9.4.0.0 < 9.4.0.30 LTS / 9.4.1.0 < 9.4.5.4 CD / 10.0.0.0 < 10.0.0.6 (7284695)
| Reporter | Title | Published | Views | Family All 11 |
|---|---|---|---|---|
| Security Bulletin: IBM MQ Appliance is affected by a heap buffer overflow vulnerability in MQPUT message option processing (CVE-2026-10572) | 29 Oct 202618:30 | – | ibm | |
| Security Bulletin: IBM MQ is affected by a denial of service vulnerability (CVE-2026-10572) | 29 Oct 202612:48 | – | ibm | |
| CVE-2026-10572 | 19 Oct 202616:51 | – | circl | |
| IBM MQ Operator buffer error vulnerability | 18 Oct 202616:00 | – | cnnvd | |
| CVE-2026-10572 | 19 Oct 202616:41 | – | cve | |
| CVE-2026-10572 IBM MQ Buffer Overflow | 19 Oct 202616:41 | – | cvelist | |
| EUVD-2026-104476 | 19 Oct 202616:41 | – | euvd | |
| CVE-2026-10572 | 19 Oct 202617:17 | – | nvd | |
| PT-2026-117490 | 19 Oct 202600:00 | – | ptsecurity | |
| CVE-2026-10572: Heap-based Buffer Overflow | 19 Oct 202600:00 | – | rapid7 |
10
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(374145);
script_version("1.3");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/02");
script_cve_id("CVE-2026-10572");
script_xref(name:"IAVA", value:"2026-A-1208");
script_name(english:"IBM MQ 9.4.0.0 < 9.4.0.30 LTS / 9.4.1.0 < 9.4.5.4 CD / 10.0.0.0 < 10.0.0.6 (7284695)");
script_set_attribute(attribute:"synopsis", value:
"The remote host is affected by a vulnerability.");
script_set_attribute(attribute:"description", value:
"The version of IBM MQ Server running on the remote host is 9.4.0.0 through 9.4.0.26 LTS, 9.4.1.0 through 9.4.5.3 CD, or
10.0.0.0 through 10.0.0.5. It is, therefore, affected by a vulnerability as referenced in the 7284695 advisory.
- IBM MQ could allow an authenticated attacker to cause a denial of service or potentially execute arbitrary code
due to a heap buffer overflow when processing MQPUT operations with malformed message options. (CVE-2026-10572)
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
script_set_attribute(attribute:"see_also", value:"https://www.ibm.com/support/pages/node/7284695");
script_set_attribute(attribute:"solution", value:
"Upgrade to IBM MQ 9.4.0.30 LTS, 9.4.5.4 CD, 10.0.0.6 or later.");
script_set_attribute(attribute:"agent", value:"all");
script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C");
script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H");
script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-10572");
script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
script_set_attribute(attribute:"exploit_available", value:"false");
script_set_attribute(attribute:"vuln_publication_date", value:"2026/10/19");
script_set_attribute(attribute:"patch_publication_date", value:"2026/10/23");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/30");
script_set_attribute(attribute:"plugin_type", value:"local");
script_set_attribute(attribute:"cpe", value:"cpe:/a:ibm:websphere_mq");
script_set_attribute(attribute:"cpe", value:"cpe:/a:ibm:mq");
script_set_attribute(attribute:"stig_severity", value:"I");
script_set_attribute(attribute:"thorough_tests", value:"true");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"Misc.");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("ibm_mq_nix_installed.nbin", "websphere_mq_installed.nasl");
script_require_keys("installed_sw/IBM WebSphere MQ");
exit(0);
}
include('vdf.inc');
# The detectors only register software IBM MQ installs, so this check is scoped to the
# software queue manager levels IBM lists in the bulletin and the registered install
# version is compared directly. MQPUT processing is a queue manager function, so
# client-only installs are filtered out.
#
# The two 9.4 service streams do not overlap numerically in this advisory - 9.4.0.x is LTS
# and 9.4.1.0 through 9.4.5.3 is CD - so each stream is one constraint and no Track filtering
# is needed.
# https://www.ibm.com/support/pages/ibm-mq-faq-long-term-support-and-continuous-delivery-releases
#
# IBM names 9.4.0.26 as the last affected LTS level and 9.4.0.30 as the fix, so the LTS branch
# is capped at the last affected level rather than compared against the fix.
# @tvdl-content
var vuln_data = {
'metadata': {'spec_version': '1.0'},
'checks': [
{
'product': {'name': 'IBM WebSphere MQ', 'type': 'app'},
'check_algorithm': 'default',
'requires': [{'scope': 'install', 'match': {'Type': 'Server'}}],
'constraints': [
{'min_version': '9.4.0.0', 'max_version': '9.4.0.26', 'fixed_display': '9.4.0.30'},
{'min_version': '9.4.1.0', 'fixed_version': '9.4.5.4'},
{'min_version': '10.0.0.0', 'fixed_version': '10.0.0.6'}
]
}
]
};
var vdf_result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_HOLE);
vdf::handle_check_and_report_errors(vdf_result:vdf_result);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
02 Nov 2026 00:00Current
6.9Medium risk
Vulners AI Score6.9
CVSS 3.18.8
EPSS0.00447
SSVC