HP-UX PHSS_36869 : HP System Management Homepage (SMH) for HP-UX, XSS (HPSBMA02274 SSRT071445 rev.3)

2007-10-16T00:00:00
ID HPUX_PHSS_36869.NASL
Type nessus
Reporter Tenable
Modified 2018-07-12T00:00:00

Description

s700_800 11.11 HP System Management Homepage A.2.2.6.2 :

Potential security vulnerabilities have been identified with HP System Management Homepage (SMH) for HP-UX. These vulnerabilities could by exploited remotely to allow cross site scripting (XSS).

                                        
                                            #
# (C) Tenable Network Security, Inc.
#
# The descriptive text and patch checks in this plugin were 
# extracted from HP patch PHSS_36869. The text itself is
# copyright (C) Hewlett-Packard Development Company, L.P.
#

include("compat.inc");

if (description)
{
  script_id(27063);
  script_version("1.14");
  script_cvs_date("Date: 2018/07/12 19:01:15");

  script_cve_id("CVE-2007-5302");
  script_bugtraq_id(25953);
  script_xref(name:"HP", value:"emr_na-c01183265");
  script_xref(name:"HP", value:"SSRT071445");

  script_name(english:"HP-UX PHSS_36869 : HP System Management Homepage (SMH) for HP-UX, XSS (HPSBMA02274 SSRT071445 rev.3)");
  script_summary(english:"Checks for the patch in the swlist output");

  script_set_attribute(
    attribute:"synopsis", 
    value:"The remote HP-UX host is missing a security-related patch."
  );
  script_set_attribute(
    attribute:"description", 
    value:
"s700_800 11.11 HP System Management Homepage A.2.2.6.2 : 

Potential security vulnerabilities have been identified with HP System
Management Homepage (SMH) for HP-UX. These vulnerabilities could by
exploited remotely to allow cross site scripting (XSS)."
  );
  # http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01183265
  script_set_attribute(
    attribute:"see_also",
    value:"http://www.nessus.org/u?0a1bd9b5"
  );
  script_set_attribute(
    attribute:"solution", 
    value:"Install patch PHSS_36869 or subsequent."
  );
  script_set_cvss_base_vector("CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");
  script_cwe_id(79);

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:hp:hp-ux");

  script_set_attribute(attribute:"patch_publication_date", value:"2007/08/21");
  script_set_attribute(attribute:"patch_modification_date", value:"2008/02/11");
  script_set_attribute(attribute:"plugin_publication_date", value:"2007/10/16");
  script_set_attribute(attribute:"vuln_publication_date", value:"2007/10/08");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_copyright(english:"This script is Copyright (C) 2007-2018 Tenable Network Security, Inc.");
  script_family(english:"HP-UX Local Security Checks");

  script_dependencies("ssh_get_info.nasl");
  script_require_keys("Host/local_checks_enabled", "Host/HP-UX/version", "Host/HP-UX/swlist");

  exit(0);
}


include("audit.inc");
include("global_settings.inc");
include("hpux.inc");


if (!get_kb_item("Host/local_checks_enabled")) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);
if (!get_kb_item("Host/HP-UX/version")) audit(AUDIT_OS_NOT, "HP-UX");
if (!get_kb_item("Host/HP-UX/swlist")) audit(AUDIT_PACKAGE_LIST_MISSING);

if (!hpux_check_ctx(ctx:"11.11"))
{
  exit(0, "The host is not affected since PHSS_36869 applies to a different OS release.");
}

patches = make_list("PHSS_36869");
foreach patch (patches)
{
  if (hpux_installed(app:patch))
  {
    exit(0, "The host is not affected because patch "+patch+" is installed.");
  }
}


flag = 0;
if (hpux_check_patch(app:"SysMgmtHomepage.SMH-RUN", version:"A.2.2.6.2")) flag++;


if (flag)
{
  if (report_verbosity > 0) security_warning(port:0, extra:hpux_report_get());
  else security_warning(0);
  exit(0);
}
else audit(AUDIT_HOST_NOT, "affected");