Google Chrome < 10.0.648.205 Multiple Vulnerabilities

2011-04-13T00:00:00
ID GOOGLE_CHROME_APSA11-02.NASL
Type nessus
Reporter Tenable
Modified 2018-11-15T00:00:00

Description

The version of Google Chrome installed on the remote host is earlier than 10.0.648.205. Such versions are affected by multiple vulnerabilities :

  • An off-by-three issue exists in the GPU process. (CVE-2011-1300)

  • A use-after-free issue exists in the GPU process. (CVE-2011-1301)

  • A heap overflow issue exists in the GPU process. (CVE-2011-1302)

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include("compat.inc");

if (description)
{
  script_id(53392);
  script_version("1.14");
  script_cvs_date("Date: 2018/11/15 20:50:27");

  script_cve_id("CVE-2011-1300", "CVE-2011-1301", "CVE-2011-1302");
  script_bugtraq_id(47377);
  script_xref(name:"Secunia", value:"44141");

  script_name(english:"Google Chrome < 10.0.648.205 Multiple Vulnerabilities");
  script_summary(english:"Checks version number of Google Chrome");

  script_set_attribute(attribute:"synopsis", value:
"The remote host contains a web browser that is affected by multiple
vulnerabilities.");

  script_set_attribute(attribute:"description", value:
"The version of Google Chrome installed on the remote host is earlier
than 10.0.648.205.  Such versions are affected by multiple
vulnerabilities :

  - An off-by-three issue exists in the GPU process.
    (CVE-2011-1300)

  - A use-after-free issue exists in the GPU process.
    (CVE-2011-1301)

  - A heap overflow issue exists in the GPU process.
    (CVE-2011-1302)");

  script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?bde4912e");
  script_set_attribute(attribute:"solution", value:"Upgrade to Google Chrome 10.0.648.205 or later.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2011/04/11");
  script_set_attribute(attribute:"patch_publication_date", value:"2011/04/14");
  script_set_attribute(attribute:"plugin_publication_date", value:"2011/04/13");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:google:chrome");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"Windows");

  script_copyright(english:"This script is Copyright (C) 2011-2018 Tenable Network Security, Inc.");

  script_dependencies("google_chrome_installed.nasl");
  script_require_keys("SMB/Google_Chrome/Installed");

  exit(0);
}

include("google_chrome_version.inc");

get_kb_item_or_exit("SMB/Google_Chrome/Installed");

installs = get_kb_list("SMB/Google_Chrome/*");
google_chrome_check_version(installs:installs, fix:'10.0.648.205', severity:SECURITY_HOLE);