GLSA-200408-16 : glibc: Information leak with LD_DEBUG

2004-08-30T00:00:00
ID GENTOO_GLSA-200408-16.NASL
Type nessus
Reporter Tenable
Modified 2018-08-10T00:00:00

Description

The remote host is affected by the vulnerability described in GLSA-200408-16 (glibc: Information leak with LD_DEBUG)

Silvio Cesare discovered a potential information leak in glibc. It     allows LD_DEBUG on SUID binaries where it should not be allowed. This     has various security implications, which may be used to gain     confidential information.

Impact :

An attacker can gain the list of symbols a SUID application uses and     their locations and can then use a trojaned library taking precendence     over those symbols to gain information or perform further exploitation.

Workaround :

There is no known workaround at this time. All users are encouraged to     upgrade to the latest available version of glibc.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#
# The descriptive text and package checks in this plugin were
# extracted from Gentoo Linux Security Advisory GLSA 200408-16.
#
# The advisory text is Copyright (C) 2001-2016 Gentoo Foundation, Inc.
# and licensed under the Creative Commons - Attribution / Share Alike 
# license. See http://creativecommons.org/licenses/by-sa/3.0/
#

include("compat.inc");

if (description)
{
  script_id(14572);
  script_version("1.14");
  script_cvs_date("Date: 2018/08/10 18:07:05");

  script_cve_id("CVE-2004-1453");
  script_xref(name:"GLSA", value:"200408-16");

  script_name(english:"GLSA-200408-16 : glibc: Information leak with LD_DEBUG");
  script_summary(english:"Checks for updated package(s) in /var/db/pkg");

  script_set_attribute(
    attribute:"synopsis", 
    value:
"The remote Gentoo host is missing one or more security-related
patches."
  );
  script_set_attribute(
    attribute:"description", 
    value:
"The remote host is affected by the vulnerability described in GLSA-200408-16
(glibc: Information leak with LD_DEBUG)

    Silvio Cesare discovered a potential information leak in glibc. It
    allows LD_DEBUG on SUID binaries where it should not be allowed. This
    has various security implications, which may be used to gain
    confidential information.
  
Impact :

    An attacker can gain the list of symbols a SUID application uses and
    their locations and can then use a trojaned library taking precendence
    over those symbols to gain information or perform further exploitation.
  
Workaround :

    There is no known workaround at this time. All users are encouraged to
    upgrade to the latest available version of glibc."
  );
  script_set_attribute(
    attribute:"see_also",
    value:"https://security.gentoo.org/glsa/200408-16"
  );
  script_set_attribute(
    attribute:"solution", 
    value:
"All glibc users should upgrade to the latest version:
    # emerge sync
    # emerge -pv your_version
    # emerge your_version"
  );
  script_set_cvss_base_vector("CVSS2#AV:L/AC:L/Au:N/C:P/I:N/A:N");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:gentoo:linux:glibc");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:gentoo:linux");

  script_set_attribute(attribute:"patch_publication_date", value:"2004/08/16");
  script_set_attribute(attribute:"plugin_publication_date", value:"2004/08/30");
  script_set_attribute(attribute:"vuln_publication_date", value:"2004/08/16");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_copyright(english:"This script is Copyright (C) 2004-2018 Tenable Network Security, Inc.");
  script_family(english:"Gentoo Local Security Checks");

  script_dependencies("ssh_get_info.nasl");
  script_require_keys("Host/local_checks_enabled", "Host/Gentoo/release", "Host/Gentoo/qpkg-list", "Host/Gentoo/arch");

  exit(0);
}


include("audit.inc");
include("global_settings.inc");
include("qpkg.inc");

if (!get_kb_item("Host/local_checks_enabled")) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);
if (!get_kb_item("Host/Gentoo/release")) audit(AUDIT_OS_NOT, "Gentoo");
if (!get_kb_item("Host/Gentoo/qpkg-list")) audit(AUDIT_PACKAGE_LIST_MISSING);
ourarch = get_kb_item("Host/Gentoo/arch");
if (!ourarch) audit(AUDIT_UNKNOWN_ARCH);
if (ourarch !~ "^(ppc64)$") audit(AUDIT_ARCH_NOT, "ppc64", ourarch);

flag = 0;

if (qpkg_check(package:"sys-libs/glibc", arch:"ppc64", unaffected:make_list("ge 2.3.4.20040808"), vulnerable:make_list("le 2.3.4.20040605"))) flag++;

if (flag)
{
  if (report_verbosity > 0) security_note(port:0, extra:qpkg_report_get());
  else security_note(0);
  exit(0);
}
else
{
  tested = qpkg_tests_get();
  if (tested) audit(AUDIT_PACKAGE_NOT_AFFECTED, tested);
  else audit(AUDIT_PACKAGE_NOT_INSTALLED, "glibc");
}