Fedora 31 : wordpress (2019-f21ad78845)

2019-10-28T00:00:00
ID FEDORA_2019-F21AD78845.NASL
Type nessus
Reporter This script is Copyright (C) 2019 and is owned by Tenable, Inc. or an Affiliate thereof.
Modified 2021-05-02T00:00:00

Description

WordPress 5.2.4 Security Release

WordPress versions 5.2.3 and earlier are affected by these bugs, which are fixed in version 5.2.4.

Security Updates

  • Props to Evan Ricafort for finding an issue where stored XSS (cross-site scripting) could be added via the Customizer.

  • Props to J.D. Grimes who found and disclosed a method of viewing unauthenticated posts.

  • Props to Weston Ruter for finding a way to create a stored XSS to inject JavaScript into style tags.

  • Props to David Newman for highlighting a method to poison the cache of JSON GET requests via the Vary: Origin header.

  • Props to Eugene Kolodenker who found a server-side request forgery in the way that URLs are validated.

  • Props to Ben Bidner of the WordPress Security Team who discovered issues related to referrer validation in the admin.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora update system website. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#
# The descriptive text and package checks in this plugin were  
# extracted from Fedora Security Advisory FEDORA-2019-f21ad78845.
#

include("compat.inc");

if (description)
{
  script_id(130327);
  script_version("1.1");
  script_cvs_date("Date: 2019/10/28 10:37:21");

  script_xref(name:"FEDORA", value:"2019-f21ad78845");

  script_name(english:"Fedora 31 : wordpress (2019-f21ad78845)");
  script_summary(english:"Checks rpm output for the updated package.");

  script_set_attribute(
    attribute:"synopsis", 
    value:"The remote Fedora host is missing a security update."
  );
  script_set_attribute(
    attribute:"description", 
    value:
"**WordPress 5.2.4 Security Release**

WordPress versions 5.2.3 and earlier are affected by these bugs, which
are fixed in version 5.2.4.

**Security Updates**

  - Props to Evan Ricafort for finding an issue where stored
    XSS (cross-site scripting) could be added via the
    Customizer.

  - Props to J.D. Grimes who found and disclosed a method of
    viewing unauthenticated posts.

  - Props to Weston Ruter for finding a way to create a
    stored XSS to inject JavaScript into style tags.

  - Props to David Newman for highlighting a method to
    poison the cache of JSON GET requests via the Vary:
    Origin header.

  - Props to Eugene Kolodenker who found a server-side
    request forgery in the way that URLs are validated.

  - Props to Ben Bidner of the WordPress Security Team who
    discovered issues related to referrer validation in the
    admin.

Note that Tenable Network Security has extracted the preceding
description block directly from the Fedora update system website.
Tenable has attempted to automatically clean and format it as much as
possible without introducing additional issues."
  );
  script_set_attribute(
    attribute:"see_also",
    value:"https://bodhi.fedoraproject.org/updates/FEDORA-2019-f21ad78845"
  );
  script_set_attribute(
    attribute:"solution", 
    value:"Update the affected wordpress package."
  );
  script_set_attribute(attribute:"risk_factor", value:"High");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:fedoraproject:fedora:wordpress");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:fedoraproject:fedora:31");

  script_set_attribute(attribute:"vuln_publication_date", value:"2019/10/26");
  script_set_attribute(attribute:"patch_publication_date", value:"2019/10/26");
  script_set_attribute(attribute:"plugin_publication_date", value:"2019/10/28");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_copyright(english:"This script is Copyright (C) 2019 and is owned by Tenable, Inc. or an Affiliate thereof.");
  script_family(english:"Fedora Local Security Checks");

  script_dependencies("ssh_get_info.nasl");
  script_require_keys("Host/local_checks_enabled", "Host/RedHat/release", "Host/RedHat/rpm-list");

  exit(0);
}


include("audit.inc");
include("global_settings.inc");
include("rpm.inc");


if (!get_kb_item("Host/local_checks_enabled")) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);
release = get_kb_item("Host/RedHat/release");
if (isnull(release) || "Fedora" >!< release) audit(AUDIT_OS_NOT, "Fedora");
os_ver = pregmatch(pattern: "Fedora.*release ([0-9]+)", string:release);
if (isnull(os_ver)) audit(AUDIT_UNKNOWN_APP_VER, "Fedora");
os_ver = os_ver[1];
if (! preg(pattern:"^31([^0-9]|$)", string:os_ver)) audit(AUDIT_OS_NOT, "Fedora 31", "Fedora " + os_ver);

if (!get_kb_item("Host/RedHat/rpm-list")) audit(AUDIT_PACKAGE_LIST_MISSING);


cpu = get_kb_item("Host/cpu");
if (isnull(cpu)) audit(AUDIT_UNKNOWN_ARCH);
if ("x86_64" >!< cpu && cpu !~ "^i[3-6]86$") audit(AUDIT_LOCAL_CHECKS_NOT_IMPLEMENTED, "Fedora", cpu);


flag = 0;
if (rpm_check(release:"FC31", reference:"wordpress-5.2.4-1.fc31")) flag++;


if (flag)
{
  security_report_v4(
    port       : 0,
    severity   : SECURITY_HOLE,
    extra      : rpm_report_get()
  );
  exit(0);
}
else
{
  tested = pkg_tests_get();
  if (tested) audit(AUDIT_PACKAGE_NOT_AFFECTED, tested);
  else audit(AUDIT_PACKAGE_NOT_INSTALLED, "wordpress");
}