EulerOS 2.0 SP1 : evince (EulerOS-SA-2018-1009)

2018-01-19T00:00:00
ID EULEROS_SA-2018-1009.NASL
Type nessus
Reporter Tenable
Modified 2018-01-25T00:00:00

Description

According to the version of the evince packages installed, the EulerOS installation on the remote host is affected by the following vulnerability :

  • Command injection in evince via filename when printing to PDF. This affects versions earlier than 3.25.91.(CVE-2017-1000159)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include("compat.inc");

if (description)
{
  script_id(106150);
  script_version("$Revision: 3.2 $");
  script_cvs_date("$Date: 2018/01/25 20:11:50 $");

  script_cve_id(
    "CVE-2017-1000159"
  );
  script_osvdb_id(
    163923
  );

  script_name(english:"EulerOS 2.0 SP1 : evince (EulerOS-SA-2018-1009)");
  script_summary(english:"Checks the rpm output for the updated package.");

  script_set_attribute(attribute:"synopsis", value:
"The remote EulerOS host is missing a security update.");
  script_set_attribute(attribute:"description", value:
"According to the version of the evince packages installed, the
EulerOS installation on the remote host is affected by the following
vulnerability :

  - Command injection in evince via filename when printing
    to PDF. This affects versions earlier than
    3.25.91.(CVE-2017-1000159)

Note that Tenable Network Security has extracted the preceding
description block directly from the EulerOS security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.");
  # http://developer.huawei.com/ict/en/site-euleros/euleros/security-advisories/EulerOS-SA-2018-1009
  script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?a3e41cd8");
  script_set_attribute(attribute:"solution", value:
"Update the affected evince package.");
  script_set_cvss_base_vector("CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P");
  script_set_cvss_temporal_vector("CVSS2#E:F/RL:OF/RC:ND");
  script_set_cvss3_base_vector("CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H");
  script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"true");

  script_set_attribute(attribute:"patch_publication_date", value:"2018/01/10");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:huawei:euleros:evince");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:huawei:euleros:evince-dvi");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:huawei:euleros:evince-libs");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:huawei:euleros:evince-nautilus");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:huawei:euleros:2.0");
  script_set_attribute(attribute:"plugin_publication_date", value:"2018/01/19");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"Huawei Local Security Checks");

  script_copyright(english:"This script is Copyright (C) 2018 Tenable Network Security, Inc.");

  script_dependencies("ssh_get_info.nasl");
  script_require_keys("Host/local_checks_enabled", "Host/EulerOS/release", "Host/EulerOS/rpm-list", "Host/EulerOS/sp");

  exit(0);
}

include("audit.inc");
include("global_settings.inc");
include("rpm.inc");

if (!get_kb_item("Host/local_checks_enabled")) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);

release = get_kb_item("Host/EulerOS/release");
if (isnull(release) || release !~ "^EulerOS") audit(AUDIT_OS_NOT, "EulerOS");
if (release !~ "^EulerOS release 2\.0(\D|$)") audit(AUDIT_OS_NOT, "EulerOS 2.0");

sp = get_kb_item("Host/EulerOS/sp");
if (isnull(sp) || sp !~ "^(1)$") audit(AUDIT_OS_NOT, "EulerOS 2.0 SP1");

if (!get_kb_item("Host/EulerOS/rpm-list")) audit(AUDIT_PACKAGE_LIST_MISSING);

cpu = get_kb_item("Host/cpu");
if (isnull(cpu)) audit(AUDIT_UNKNOWN_ARCH);
if ("x86_64" >!< cpu && cpu !~ "^i[3-6]86$") audit(AUDIT_LOCAL_CHECKS_NOT_IMPLEMENTED, "EulerOS", cpu);

flag = 0;

pkgs = ["evince-3.8.3-9.h2",
        "evince-dvi-3.8.3-9.h2",
        "evince-libs-3.8.3-9.h2",
        "evince-nautilus-3.8.3-9.h2"];

foreach (pkg in pkgs)
  if (rpm_check(release:"EulerOS-2.0", sp:"1", reference:pkg)) flag++;

if (flag)
{
  security_report_v4(
    port       : 0,
    severity   : SECURITY_WARNING,
    extra      : rpm_report_get()
  );
  exit(0);
}
else
{
  tested = pkg_tests_get();
  if (tested) audit(AUDIT_PACKAGE_NOT_AFFECTED, tested);
  else audit(AUDIT_PACKAGE_NOT_INSTALLED, "evince");
}