Elasticsearch 9.0.x < 9.4.9 / 9.5.x < 9.5.6 DoS (ESA-2026-235)
| Reporter | Title | Published | Views | Family All 13 |
|---|---|---|---|---|
| CVE-2026-115715 | 3 Nov 202617:00 | – | circl | |
| CVE-2026-115715 | 3 Nov 202616:44 | – | cve | |
| CVE-2026-115715 Allocation of Resources Without Limits or Throttling in Elasticsearch Leading to Denial of Service | 3 Nov 202616:44 | – | cvelist | |
| Elasticsearch 8.19.24, 9.4.9, 9.5.6 Security Update (ESA-2026-235) | 3 Nov 202616:33 | – | elastic | |
| EUVD-2026-116080 | 3 Nov 202616:44 | – | euvd | |
| CVE-2026-115715 | 3 Nov 202616:44 | – | mend | |
| Allocation of Resources Without Limits or Throttling in Elasticsearch Leading to Denial of Service | 5 Nov 202609:03 | – | mscve | |
| CVE-2026-115715 | 3 Nov 202617:17 | – | nvd | |
| AZL-112655 CVE-2026-115715 affecting package rubygem-elasticsearch 8.9.0-1 | 3 Nov 202617:17 | – | osv_azl | |
| PT-2026-136285 | 3 Nov 202600:00 | – | ptsecurity |
10
| Source | Link |
|---|---|
| discuss | www.discuss.elastic.co/t/391372 |
| cve | www.cve.mitre.org/cgi-bin/cvename.cgi |
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(375647);
script_version("1.1");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/03");
script_cve_id("CVE-2026-115715");
script_name(english:"Elasticsearch 9.0.x < 9.4.9 / 9.5.x < 9.5.6 DoS (ESA-2026-235)");
script_set_attribute(attribute:"synopsis", value:
"The remote host is missing a security update.");
script_set_attribute(attribute:"description", value:
"The version of Elasticsearch installed on the remote host is 9.0.x prior to 9.4.9, or 9.5.x prior to 9.5.6. It is,
therefore, affected by a vulnerability as referenced in the ESA-2026-235 advisory.
- Allocation of Resources Without Limits or Throttling (CWE-770) in Elasticsearch can lead to denial of
service via a specially crafted input value that is processed by an affected phonetic encoder of the
analysis-phonetic plugin. An authenticated user with permission to write documents to or run searches
against an index that uses an affected encoder can cause an Elasticsearch node to exhaust its heap memory.
The node can become unresponsive or terminate. (CVE-2026-115715)
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
script_set_attribute(attribute:"see_also", value:"https://discuss.elastic.co/t/391372");
script_set_attribute(attribute:"solution", value:
"Upgrade to Elasticsearch version 9.4.9, or 9.5.6 or later as appropriate for your release branch.");
script_set_attribute(attribute:"agent", value:"unix");
script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C");
script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H");
script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-115715");
script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
script_set_attribute(attribute:"exploit_available", value:"false");
script_set_attribute(attribute:"vuln_publication_date", value:"2026/11/03");
script_set_attribute(attribute:"patch_publication_date", value:"2026/11/03");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/11/03");
script_set_attribute(attribute:"plugin_type", value:"combined");
script_set_attribute(attribute:"cpe", value:"cpe:/a:elasticsearch:elasticsearch");
script_set_attribute(attribute:"cpe", value:"cpe:/a:elastic:elasticsearch");
script_set_attribute(attribute:"generated_plugin", value:"current");
script_set_attribute(attribute:"thorough_tests", value:"true");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"Misc.");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("elasticsearch_detect.nbin", "elastic_elasticsearch_nix_installed.nbin");
script_require_keys("installed_sw/Elasticsearch");
exit(0);
}
include('vdf.inc');
# @tvdl-content
var vuln_data = {
"metadata": {
"spec_version": "1.0"
},
"checks": [
{
"product": {
"name": "Elasticsearch",
"type": "app"
},
"check_algorithm": "default",
"constraints": [
{
"min_version": "9.0.0",
"fixed_version": "9.4.9"
},
{
"min_version": "9.5.0",
"fixed_version": "9.5.6"
}
]
}
]
};
var vdf_result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_WARNING);
vdf::handle_check_and_report_errors(vdf_result:vdf_result);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
03 Nov 2026 00:00Current
5.9Medium risk
Vulners AI Score5.9
CVSS 3.16.5
EPSS0.00321
SSVC