Elasticsearch 8.10.x < 8.19.24 / 9.0.x < 9.4.9 / 9.5.x < 9.5.6 DoS (ESA-2026-201)
| Reporter | Title | Published | Views | Family All 13 |
|---|---|---|---|---|
| Exploit for CVE-2026-115290 | 5 Nov 202604:46 | – | githubexploit | |
| CVE-2026-115290 | 3 Nov 202616:54 | – | circl | |
| Elasticsearch resource management error vulnerability | 3 Nov 202600:00 | – | cnnvd | |
| CVE-2026-115290 | 3 Nov 202616:43 | – | cve | |
| CVE-2026-115290 Uncontrolled Recursion in Elasticsearch Leading to Denial of Service | 3 Nov 202616:43 | – | cvelist | |
| Elasticsearch 8.19.24, 9.4.9, 9.5.6 Security Update (ESA-2026-201) | 3 Nov 202616:26 | – | elastic | |
| EUVD-2026-116072 | 3 Nov 202616:43 | – | euvd | |
| CVE-2026-115290 | 3 Nov 202616:43 | – | mend | |
| CVE-2026-115290 | 3 Nov 202617:17 | – | nvd | |
| PT-2026-136276 | 3 Nov 202600:00 | – | ptsecurity |
10
| Source | Link |
|---|---|
| discuss | www.discuss.elastic.co/t/391356 |
| cve | www.cve.mitre.org/cgi-bin/cvename.cgi |
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(375644);
script_version("1.3");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/06");
script_cve_id("CVE-2026-115290");
script_name(english:"Elasticsearch 8.10.x < 8.19.24 / 9.0.x < 9.4.9 / 9.5.x < 9.5.6 DoS (ESA-2026-201)");
script_set_attribute(attribute:"synopsis", value:
"The remote host is missing a security update.");
script_set_attribute(attribute:"description", value:
"The version of Elasticsearch installed on the remote host is 8.10.x prior to 8.19.24, or 9.0.x prior to 9.4.9, or 9.5.x
prior to 9.5.6. It is, therefore, affected by a vulnerability as referenced in the ESA-2026-201 advisory.
- Uncontrolled Recursion (CWE-674) in Elasticsearch can lead to denial of service via Serialized Data with
Nested Payloads (CAPEC-230). An unauthenticated attacker with network access to the remote cluster server
interface of a node can send a specially crafted request that causes the node to terminate. No credentials
are required. The attacker can repeat the request against each reachable node. (CVE-2026-115290)
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
script_set_attribute(attribute:"see_also", value:"https://discuss.elastic.co/t/391356");
script_set_attribute(attribute:"solution", value:
"Upgrade to Elasticsearch version 8.19.24, 9.4.9, or 9.5.6 or later as appropriate for your release branch.");
script_set_attribute(attribute:"agent", value:"unix");
script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C");
script_set_cvss_temporal_vector("CVSS2#E:POC/RL:OF/RC:C");
script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H");
script_set_cvss3_temporal_vector("CVSS:3.0/E:P/RL:O/RC:C");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-115290");
script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
script_set_attribute(attribute:"exploit_available", value:"true");
script_set_attribute(attribute:"vuln_publication_date", value:"2026/11/03");
script_set_attribute(attribute:"patch_publication_date", value:"2026/11/03");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/11/03");
script_set_attribute(attribute:"plugin_type", value:"combined");
script_set_attribute(attribute:"cpe", value:"cpe:/a:elasticsearch:elasticsearch");
script_set_attribute(attribute:"cpe", value:"cpe:/a:elastic:elasticsearch");
script_set_attribute(attribute:"generated_plugin", value:"current");
script_set_attribute(attribute:"thorough_tests", value:"true");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"Misc.");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("elasticsearch_detect.nbin", "elastic_elasticsearch_nix_installed.nbin");
script_require_keys("installed_sw/Elasticsearch");
exit(0);
}
include('vdf.inc');
# @tvdl-content
var vuln_data = {
"metadata": {
"spec_version": "1.0"
},
"checks": [
{
"product": {
"name": "Elasticsearch",
"type": "app"
},
"check_algorithm": "default",
"constraints": [
{
"min_version": "8.10.0",
"fixed_version": "8.19.24"
},
{
"min_version": "9.0.0",
"fixed_version": "9.4.9"
},
{
"min_version": "9.5.0",
"fixed_version": "9.5.6"
}
]
}
]
};
var vdf_result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_HOLE);
vdf::handle_check_and_report_errors(vdf_result:vdf_result);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
06 Nov 2026 00:00Current
6Medium risk
Vulners AI Score6
CVSS 3.17.5
EPSS0.00413
SSVC