Docker Desktop < 4.97.0 Multiple Vulnerabilities
| Reporter | Title | Published | Views | Family All 240 |
|---|---|---|---|---|
| Exploit for CVE-2026-99999 | 18 Oct 202613:16 | – | githubexploit | |
| Exploit for CVE-2026-99999 | 17 Oct 202608:58 | – | githubexploit | |
| Exploit for CVE-2022-99999 | 25 Oct 202606:15 | – | githubexploit | |
| Exploit for CVE-2026-99999 | 19 Oct 202609:44 | – | githubexploit | |
| Exploit for CVE-2026-99999 | 20 Oct 202608:45 | – | githubexploit | |
| Exploit for CVE-2026-99999 | 20 Oct 202608:46 | – | githubexploit | |
| Exploit for CVE-2026-99999 | 25 Oct 202606:18 | – | githubexploit | |
| Exploit for CVE-2026-99999 | 20 Oct 202607:06 | – | githubexploit | |
| Exploit for CVE-2026-99999 | 18 Oct 202609:44 | – | githubexploit | |
| Exploit for CVE-2026-99999 | 19 Oct 202605:06 | – | githubexploit |
10
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(374216);
script_version("1.2");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/11/02");
script_cve_id("CVE-2026-99999", "CVE-2026-114409");
script_xref(name:"IAVA", value:"2026-A-1216");
script_name(english:"Docker Desktop < 4.97.0 Multiple Vulnerabilities");
script_set_attribute(attribute:"synopsis", value:
"The remote host has an application installed that is affected by multiple vulnerabilities.");
script_set_attribute(attribute:"description", value:
"The version of Docker Desktop installed on the remote host is prior to 4.97.0. It is, therefore, affected by multiple
vulnerabilities:
- A kernel vulnerability where a container could exploit bad IPv4 checksum metadata via TUN or AF_PACKET to corrupt
the VM's network stack. If a packet with bad checksum metadata gets into the IPv4 stack, skb_checksum_help can
corrupt the network header and cause further mischief. (CVE-2026-99999)
- Docker Desktop could write third-party API keys and OAuth access tokens in cleartext to local application logs and
diagnostics bundles due to insufficient IPC payload redaction. An attacker with read access to these files could
obtain the credentials. These OAuth tokens are not Docker account tokens. (CVE-2026-114409)
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
script_set_attribute(attribute:"see_also", value:"https://docs.docker.com/desktop/release-notes/#4970");
script_set_attribute(attribute:"solution", value:
"Upgrade to Docker Desktop version 4.97.0 or later.");
script_set_attribute(attribute:"agent", value:"all");
script_set_cvss_base_vector("CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C");
script_set_cvss_temporal_vector("CVSS2#E:POC/RL:OF/RC:C");
script_set_cvss3_base_vector("CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H");
script_set_cvss3_temporal_vector("CVSS:3.0/E:P/RL:O/RC:C");
script_set_attribute(attribute:"cvss4_vector", value:"CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N");
script_set_attribute(attribute:"cvss4_threat_vector", value:"CVSS:4.0/E:P");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-99999");
script_set_attribute(attribute:"cvss4_score_source", value:"CVE-2026-114409");
script_set_attribute(attribute:"exploitability_ease", value:"Exploits are available");
script_set_attribute(attribute:"exploit_available", value:"true");
script_cwe_id(20, 532);
script_set_attribute(attribute:"vuln_publication_date", value:"2026/10/15");
script_set_attribute(attribute:"patch_publication_date", value:"2026/10/26");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/30");
script_set_attribute(attribute:"plugin_type", value:"local");
script_set_attribute(attribute:"cpe", value:"cpe:/a:docker:docker");
script_set_attribute(attribute:"stig_severity", value:"I");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"Misc.");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("docker_for_linux_installed.nbin", "docker_for_mac_installed.nbin", "docker_for_windows_installed.nbin");
script_require_ports("installed_sw/Docker Desktop");
exit(0);
}
include('vdf.inc');
# @tvdl-content
var vuln_data = {
'metadata': {'spec_version': '1.0'},
'checks': [
{
'product': {'name': 'Docker Desktop', 'type': 'app'},
'check_algorithm': 'default',
'constraints': [
{'min_version': '4.39.0', 'fixed_version': '4.97.0'},
{'fixed_version': '4.97.0', 'report': {'cves': ['CVE-2026-99999']}}
]
}
]
};
var result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_HOLE);
vdf::handle_check_and_report_errors(vdf_result:result);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
02 Nov 2026 00:00Current
8.3High risk
Vulners AI Score8.3
CVSS 45.7
CVSS 3.19.3
EPSS0.00788
SSVC