Debian DSA-4350-1 : policykit-1 - security update

2018-12-07T00:00:00
ID DEBIAN_DSA-4350.NASL
Type nessus
Reporter Tenable
Modified 2019-02-06T00:00:00

Description

It was discovered that incorrect processing of very high UIDs in Policykit, a framework for managing administrative policies and privileges, could result in authentication bypass.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#
# The descriptive text and package checks in this plugin were  
# extracted from Debian Security Advisory DSA-4350. The text 
# itself is copyright (C) Software in the Public Interest, Inc.
#

include("compat.inc");

if (description)
{
  script_id(119480);
  script_version("1.2");
  script_cvs_date("Date: 2019/02/06 11:41:38");

  script_cve_id("CVE-2018-19788");
  script_xref(name:"DSA", value:"4350");

  script_name(english:"Debian DSA-4350-1 : policykit-1 - security update");
  script_summary(english:"Checks dpkg output for the updated package");

  script_set_attribute(
    attribute:"synopsis", 
    value:"The remote Debian host is missing a security-related update."
  );
  script_set_attribute(
    attribute:"description", 
    value:
"It was discovered that incorrect processing of very high UIDs in
Policykit, a framework for managing administrative policies and
privileges, could result in authentication bypass."
  );
  script_set_attribute(
    attribute:"see_also",
    value:"https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=915332"
  );
  script_set_attribute(
    attribute:"see_also",
    value:"https://security-tracker.debian.org/tracker/source-package/policykit-1"
  );
  script_set_attribute(
    attribute:"see_also",
    value:"https://packages.debian.org/source/stretch/policykit-1"
  );
  script_set_attribute(
    attribute:"see_also",
    value:"https://www.debian.org/security/2018/dsa-4350"
  );
  script_set_attribute(
    attribute:"solution", 
    value:
"Upgrade the policykit-1 packages.

For the stable distribution (stretch), this problem has been fixed in
version 0.105-18+deb9u1."
  );
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:debian:debian_linux:policykit-1");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:debian:debian_linux:9.0");

  script_set_attribute(attribute:"vuln_publication_date", value:"2018/12/03");
  script_set_attribute(attribute:"patch_publication_date", value:"2018/12/06");
  script_set_attribute(attribute:"plugin_publication_date", value:"2018/12/07");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_copyright(english:"This script is Copyright (C) 2018-2019 and is owned by Tenable, Inc. or an Affiliate thereof.");
  script_family(english:"Debian Local Security Checks");

  script_dependencies("ssh_get_info.nasl");
  script_require_keys("Host/local_checks_enabled", "Host/Debian/release", "Host/Debian/dpkg-l");

  exit(0);
}


include("audit.inc");
include("debian_package.inc");


if (!get_kb_item("Host/local_checks_enabled")) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);
if (!get_kb_item("Host/Debian/release")) audit(AUDIT_OS_NOT, "Debian");
if (!get_kb_item("Host/Debian/dpkg-l")) audit(AUDIT_PACKAGE_LIST_MISSING);


flag = 0;
if (deb_check(release:"9.0", prefix:"gir1.2-polkit-1.0", reference:"0.105-18+deb9u1")) flag++;
if (deb_check(release:"9.0", prefix:"libpolkit-agent-1-0", reference:"0.105-18+deb9u1")) flag++;
if (deb_check(release:"9.0", prefix:"libpolkit-agent-1-dev", reference:"0.105-18+deb9u1")) flag++;
if (deb_check(release:"9.0", prefix:"libpolkit-backend-1-0", reference:"0.105-18+deb9u1")) flag++;
if (deb_check(release:"9.0", prefix:"libpolkit-backend-1-dev", reference:"0.105-18+deb9u1")) flag++;
if (deb_check(release:"9.0", prefix:"libpolkit-gobject-1-0", reference:"0.105-18+deb9u1")) flag++;
if (deb_check(release:"9.0", prefix:"libpolkit-gobject-1-dev", reference:"0.105-18+deb9u1")) flag++;
if (deb_check(release:"9.0", prefix:"policykit-1", reference:"0.105-18+deb9u1")) flag++;
if (deb_check(release:"9.0", prefix:"policykit-1-doc", reference:"0.105-18+deb9u1")) flag++;

if (flag)
{
  if (report_verbosity > 0) security_hole(port:0, extra:deb_report_get());
  else security_hole(0);
  exit(0);
}
else audit(AUDIT_HOST_NOT, "affected");