Debian DSA-051-1 : netscape - unexpected javascript execution

2004-09-29T00:00:00
ID DEBIAN_DSA-051.NASL
Type nessus
Reporter This script is Copyright (C) 2004-2019 Tenable Network Security, Inc.
Modified 2020-06-02T00:00:00

Description

Florian Wesch has discovered a problem (reported to bugtraq) with the way how Netscape handles comments in GIF files. The Netscape browser does not escape the GIF file comment in the image information page. This allows JavaScript execution in the

                                        
                                            #%NASL_MIN_LEVEL 80502

#
# (C) Tenable Network Security, Inc.
#
# The descriptive text and package checks in this plugin were  
# extracted from Debian Security Advisory DSA-051. The text 
# itself is copyright (C) Software in the Public Interest, Inc.
#

include("compat.inc");

if (description)
{
  script_id(14888);
  script_version("1.18");
  script_cvs_date("Date: 2019/08/02 13:32:16");

  script_cve_id("CVE-2001-0596");
  script_xref(name:"DSA", value:"051");

  script_name(english:"Debian DSA-051-1 : netscape - unexpected javascript execution");
  script_summary(english:"Checks dpkg output for the updated package");

  script_set_attribute(
    attribute:"synopsis", 
    value:"The remote Debian host is missing a security-related update."
  );
  script_set_attribute(
    attribute:"description", 
    value:
"Florian Wesch has discovered a problem (reported to bugtraq) with the
 way how Netscape handles comments in GIF files. The Netscape browser
 does not escape the GIF file comment in the image information page.
 This allows JavaScript execution in the 'about:' protocol and can for
 example be used to upload the History (about:global) to a webserver,
 thus leaking private information. This problem has been fixed
 upstream in Netscape 4.77.

Since we haven't received source code for these packages, they are not
part of the Debian GNU/Linux distribution, but are packaged up as
`.deb' files for a convenient installation."
  );
  script_set_attribute(
    attribute:"see_also",
    value:"http://www.debian.org/security/2001/dsa-051"
  );
  script_set_attribute(
    attribute:"solution", 
    value:"Upgrade the Netscape packages immediately and remove older versions."
  );
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:debian:debian_linux:netscape");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:debian:debian_linux:2.2");

  script_set_attribute(attribute:"patch_publication_date", value:"2001/04/23");
  script_set_attribute(attribute:"plugin_publication_date", value:"2004/09/29");
  script_set_attribute(attribute:"vuln_publication_date", value:"2001/04/09");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_copyright(english:"This script is Copyright (C) 2004-2019 Tenable Network Security, Inc.");
  script_family(english:"Debian Local Security Checks");

  script_dependencies("ssh_get_info.nasl");
  script_require_keys("Host/local_checks_enabled", "Host/Debian/release", "Host/Debian/dpkg-l");

  exit(0);
}


include("audit.inc");
include("debian_package.inc");


if (!get_kb_item("Host/local_checks_enabled")) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);
if (!get_kb_item("Host/Debian/release")) audit(AUDIT_OS_NOT, "Debian");
if (!get_kb_item("Host/Debian/dpkg-l")) audit(AUDIT_PACKAGE_LIST_MISSING);


flag = 0;
if (deb_check(release:"2.2", prefix:"communicator", reference:"4.77-1")) flag++;
if (deb_check(release:"2.2", prefix:"communicator-base-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"communicator-nethelp-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"communicator-smotif-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"communicator-spellchk-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"navigator", reference:"4.77-1")) flag++;
if (deb_check(release:"2.2", prefix:"navigator-base-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"navigator-nethelp-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"navigator-smotif-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"netscape", reference:"4.77-1")) flag++;
if (deb_check(release:"2.2", prefix:"netscape-base-4", reference:"4.77-1")) flag++;
if (deb_check(release:"2.2", prefix:"netscape-base-4-libc5", reference:"4.77-1")) flag++;
if (deb_check(release:"2.2", prefix:"netscape-base-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"netscape-ja-resource-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"netscape-java-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"netscape-ko-resource-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"netscape-smotif-477", reference:"4.77-2")) flag++;
if (deb_check(release:"2.2", prefix:"netscape-zh-resource-477", reference:"4.77-2")) flag++;

if (flag)
{
  if (report_verbosity > 0) security_hole(port:0, extra:deb_report_get());
  else security_hole(0);
  exit(0);
}
else audit(AUDIT_HOST_NOT, "affected");