Lucene search
+L

Atlassian Confluence < 9.2.26 / 9.3.x < 10.2.19 / 11.0.0 (CONFSERVER-104520)

🗓️ 21 Oct 2026 00:00:00Reported by TenableType 
nessus
 nessus
🔗 www.tenable.com👁 8 Views

Unauthenticated remote attacker can bypass mutual TLS requirements in Atlassian Confluence.

Related
Refs
Code
ReporterTitlePublishedViews
Family
ibm
IBM Security Bulletins
Security Bulletin: IBM SPSS Modeler is affected by multiple vulnerabilities in Netty
11 Sep 202616:07
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Multiple Security Vulnerabilities in Netty affect IBM Sterling B2B Integrator and IBM Sterling File Gateway
22 Oct 202621:01
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM Guardium Data Protection is affected by multiple vulnerabilities (CVE-2026-75595, CVE-2026-75596, CVE-2026-62243)
20 Oct 202615:08
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM Watson Speech Services Cartridge is vulnerable to multiple issues in Netty (CVE-2026-62243, CVE-2026-75595, CVE-2026-75596)
22 Oct 202620:01
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM App Connect for Manufacturing is vulnerable to multiple vulnerabilities due to Netty and Milo
16 Sep 202607:42
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM SPSS Analytic Server is affected by multiple vulnerabilities in Netty
15 Sep 202609:44
–ibm
ibm
IBM Security Bulletins
Security Bulletin:Vulnerabilities exists in Netty package used by IBM Netezza Appliance
12 Oct 202607:55
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Multiple vulnerabilties in DevOps Test Hub
14 Oct 202616:29
–ibm
ibm
IBM Security Bulletins
Security Bulletin:Netty Vulnerability: IndexOutOfBoundsException in SslClientHelloHandler Leading to Mutual TLS Bypass
6 Oct 202617:51
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Multiple security vulnerabilities in IBM Process Automation Manager Open Edition Starter Kit for Banking
15 Oct 202614:38
–ibm
Rows per page
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##

include('compat.inc');

if (description)
{
  script_id(368977);
  script_version("1.1");
  script_set_attribute(attribute:"plugin_modification_date", value:"2026/10/21");

  script_cve_id("CVE-2026-75595");

  script_name(english:"Atlassian Confluence < 9.2.26 / 9.3.x < 10.2.19 / 11.0.0 (CONFSERVER-104520)");

  script_set_attribute(attribute:"synopsis", value:
"The remote Atlassian Confluence host is missing a security update.");
  script_set_attribute(attribute:"description", value:
"The version of Atlassian Confluence Server running on the remote host is affected by a vulnerability as referenced in
the CONFSERVER-104520 advisory.

  - Netty is an asynchronous, event-driven network application framework. Prior to 4.1.137.Fina and
    4.2.17.Final, io.netty.handler.ssl.SslClientHelloHandler#decode checks the wrong offset before reading the
    four-byte TLS handshake header, so a ClientHello whose handshake header spans records can cause an
    IndexOutOfBoundsException and invoke select(ctx, null). This selects the default SslContext instead of the
    SNI-specific context. In deployments where per-SNI clientAuth=REQUIRE is the sole mutual TLS gate, the
    default SslContext uses clientAuth=NONE or clientAuth=OPTIONAL, and no application-layer certificate
    verification exists, an unauthenticated remote attacker can bypass the protected route's mutual TLS
    requirement. This issue is fixed in versions 4.1.137.Final and 4.2.17.Final. (CVE-2026-75595)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
  script_set_attribute(attribute:"see_also", value:"https://jira.atlassian.com/browse/CONFSERVER-104520");
  script_set_attribute(attribute:"solution", value:
"Upgrade to Atlassian Confluence version 9.2.26, 10.2.19, 11.0.0 or later.");
  script_set_attribute(attribute:"agent", value:"all");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
  script_set_attribute(attribute:"cvss4_vector", value:"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N");
  script_set_attribute(attribute:"cvss4_threat_vector", value:"CVSS:4.0/E:U");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-75595");

  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2026/08/19");
  script_set_attribute(attribute:"patch_publication_date", value:"2026/10/16");
  script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/21");

  script_set_attribute(attribute:"plugin_type", value:"combined");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:atlassian:confluence");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_set_attribute(attribute:"thorough_tests", value:"true");
  script_set_attribute(attribute:"enable_cgi_scanning", value:"true");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("confluence_detect.nasl", "confluence_nix_installed.nbin", "confluence_win_installed.nbin");
  script_require_keys("installed_sw/Atlassian Confluence");

  exit(0);
}

include('vdf.inc');

# @tvdl-content-verify-only
var vuln_data = {
  "metadata": {
    "spec_version": "1.0"
  },
  "checks": [
    {
      "product": {
        "name": "Atlassian Confluence",
        "type": "app"
      },
      "check_algorithm": "default",
      "constraints": [
        {
          "fixed_version": "9.2.26",
          "fixed_display": "9.2.26 / 10.2.19 / 11.0.0"
        },
        {
          "min_version": "9.3.1",
          "fixed_version": "10.2.19",
          "fixed_display": "10.2.19 / 11.0.0"
        }
      ]
    }
  ]
};

var vdf_result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_HOLE);
vdf::handle_check_and_report_errors(vdf_result:vdf_result);

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

21 Oct 2026 00:00Current
6.4Medium risk
Vulners AI Score6.4
CVSS 3.19.1
CVSS 49.1
EPSS0.00316
SSVC
8