Atlassian Confluence < 9.2.26 / 9.3.x < 10.2.19 / 11.0.0 (CONFSERVER-104506)
10
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##
include('compat.inc');
if (description)
{
script_id(368960);
script_version("1.2");
script_set_attribute(attribute:"plugin_modification_date", value:"2026/10/30");
script_cve_id("CVE-2026-62243");
script_xref(name:"IAVA", value:"2026-A-1185");
script_name(english:"Atlassian Confluence < 9.2.26 / 9.3.x < 10.2.19 / 11.0.0 (CONFSERVER-104506)");
script_set_attribute(attribute:"synopsis", value:
"The remote Atlassian Confluence host is missing a security update.");
script_set_attribute(attribute:"description", value:
"The version of Atlassian Confluence Server running on the remote host is affected by a vulnerability as referenced in
the CONFSERVER-104506 advisory.
- Netty (io.netty:netty-handler) versions from 4.2.0.Final through 4.2.16.Final and versions through
4.1.136.Final disable TLS hostname verification on the SslProvider.OPENSSL client path when a plain (non-
extended) X509TrustManager is used and Unsafe-based trust-manager wrapping is unavailable (Java 25+). In
this configuration the OpenSSL client does not perform hostname verification, allowing a man-in-the-middle
attacker to present a certificate issued for a different hostname that is accepted without validation.
Fixed in 4.2.17.Final and 4.1.137.Final. (CVE-2026-62243)
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
script_set_attribute(attribute:"see_also", value:"https://jira.atlassian.com/browse/CONFSERVER-104506");
script_set_attribute(attribute:"solution", value:
"Upgrade to Atlassian Confluence version 9.2.26, 10.2.19, 11.0.0 or later.");
script_set_attribute(attribute:"agent", value:"all");
script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:N");
script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N");
script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
script_set_attribute(attribute:"cvss4_vector", value:"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N");
script_set_attribute(attribute:"cvss4_threat_vector", value:"CVSS:4.0/E:U");
script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-62243");
script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
script_set_attribute(attribute:"exploit_available", value:"false");
script_set_attribute(attribute:"vuln_publication_date", value:"2026/08/22");
script_set_attribute(attribute:"patch_publication_date", value:"2026/10/16");
script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/21");
script_set_attribute(attribute:"plugin_type", value:"combined");
script_set_attribute(attribute:"cpe", value:"cpe:/a:atlassian:confluence");
script_set_attribute(attribute:"generated_plugin", value:"current");
script_set_attribute(attribute:"thorough_tests", value:"true");
script_set_attribute(attribute:"enable_cgi_scanning", value:"true");
script_set_attribute(attribute:"stig_severity", value:"I");
script_end_attributes();
script_category(ACT_GATHER_INFO);
script_family(english:"CGI abuses");
script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");
script_dependencies("confluence_detect.nasl", "confluence_nix_installed.nbin", "confluence_win_installed.nbin");
script_require_keys("installed_sw/Atlassian Confluence");
exit(0);
}
include('vdf.inc');
# @tvdl-content-verify-only
var vuln_data = {
"metadata": {
"spec_version": "1.0"
},
"checks": [
{
"product": {
"name": "Atlassian Confluence",
"type": "app"
},
"check_algorithm": "default",
"constraints": [
{
"fixed_version": "9.2.26",
"fixed_display": "9.2.26 / 10.2.19 / 11.0.0"
},
{
"min_version": "9.3.1",
"fixed_version": "10.2.19",
"fixed_display": "10.2.19 / 11.0.0"
}
]
}
]
};
var vdf_result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_HOLE);
vdf::handle_check_and_report_errors(vdf_result:vdf_result);
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
30 Oct 2026 00:00Current
7.4High risk
Vulners AI Score7.4
CVSS 3.17.5
CVSS 48.7
EPSS0.00155
SSVC