Lucene search
+L

Atlassian Confluence 7.16.x < 9.2.26 / 9.3.x < 10.2.19 / 11.0.0 (CONFSERVER-104504)

🗓️ 21 Oct 2026 00:00:00Reported by TenableType 
nessus
 nessus
🔗 www.tenable.com👁 4 Views

Algorithmic DoS in Atlassian Confluence via user-supplied Spring Expression Language.

Related
Refs
Code
ReporterTitlePublishedViews
Family
ibm
IBM Security Bulletins
Security Bulletin: IBM Sterling Control Center is affected by multiple vulnerabilities in spring-expression jar
27 Jul 202607:37
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM Watson Speech Services Cartridge is vulnerable to multiple issues in Spring Framework [CVE-2026-41850, CVE-2026-41851, CVE-2026-41852]
27 Jul 202620:05
–ibm
ibm
IBM Security Bulletins
Security Bulletin:Vulnerability in spring affects IBM Netezza Appliance
10 Aug 202610:14
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM Sterling Connect:Direct Web Services is Affected by Multiple Vulnerabilities.
22 Jul 202607:58
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM Terracotta is affected by a Spring Framework vulnerability that could allow Denial of Service (Dos) attacks, and Incorrect Authorization attacks
26 Jun 202618:29
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Multiple vulnerabilities in IBM DevOps Solution Workbench
13 Aug 202607:26
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Vulnerabilities in spring-core-5.3.25.jar and spring-expression-6.1.11.jar (CVE-2026-41850, CVE-2026-41851, CVE-2026-41852, CVE-2026-41848) affect IBM PowerVM Novalink.
28 Aug 202615:41
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Multiple vulnerabilities in Spring Boot's Cassandra have been addressed in IBM webMethods API Management
28 Aug 202604:56
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Multiple security vulnerabilities are addressed with IBM Cloud Pak for Business Automation iFixes for August 2026.
1 Sep 202618:47
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM Db2 Developer Extension is affected by vulnerability in Spring Expression (CVE-2026-41850, CVE-2026-41851,CVE-2026-41852 )
17 Sep 202619:57
–ibm
Rows per page
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##

include('compat.inc');

if (description)
{
  script_id(368967);
  script_version("1.1");
  script_set_attribute(attribute:"plugin_modification_date", value:"2026/10/21");

  script_cve_id("CVE-2026-41850");

  script_name(english:"Atlassian Confluence 7.16.x < 9.2.26 / 9.3.x < 10.2.19 / 11.0.0 (CONFSERVER-104504)");

  script_set_attribute(attribute:"synopsis", value:
"The remote Atlassian Confluence host is missing a security update.");
  script_set_attribute(attribute:"description", value:
"The version of Atlassian Confluence Server running on the remote host is affected by a vulnerability as referenced in
the CONFSERVER-104504 advisory.

  - Applications that evaluate user-supplied Spring Expression Language (SpEL) expressions are vulnerable to
    an Algorithmic Denial of Service (DoS). By providing a specially crafted expression, an attacker can
    trigger excessive resource consumption during evaluation, leading to application degradation or
    unavailability. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0
    through 6.1.27; 5.3.0 through 5.3.48. (CVE-2026-41850)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
  script_set_attribute(attribute:"see_also", value:"https://jira.atlassian.com/browse/CONFSERVER-104504");
  script_set_attribute(attribute:"solution", value:
"Upgrade to Atlassian Confluence version 9.2.26, 10.2.19, 11.0.0 or later.");
  script_set_attribute(attribute:"agent", value:"all");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-41850");

  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2026/06/09");
  script_set_attribute(attribute:"patch_publication_date", value:"2026/10/16");
  script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/21");

  script_set_attribute(attribute:"plugin_type", value:"combined");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:atlassian:confluence");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_set_attribute(attribute:"thorough_tests", value:"true");
  script_set_attribute(attribute:"enable_cgi_scanning", value:"true");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("confluence_detect.nasl", "confluence_nix_installed.nbin", "confluence_win_installed.nbin");
  script_require_keys("installed_sw/Atlassian Confluence");

  exit(0);
}

include('vdf.inc');

# @tvdl-content-verify-only
var vuln_data = {
  "metadata": {
    "spec_version": "1.0"
  },
  "checks": [
    {
      "product": {
        "name": "Atlassian Confluence",
        "type": "app"
      },
      "check_algorithm": "default",
      "constraints": [
        {
          "min_version": "7.16.0",
          "fixed_version": "9.2.26",
          "fixed_display": "9.2.26 / 10.2.19 / 11.0.0"
        },
        {
          "min_version": "9.3.1",
          "fixed_version": "10.2.19",
          "fixed_display": "10.2.19 / 11.0.0"
        }
      ]
    }
  ]
};

var vdf_result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_HOLE);
vdf::handle_check_and_report_errors(vdf_result:vdf_result);

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

21 Oct 2026 00:00Current
6.7Medium risk
Vulners AI Score6.7
CVSS 3.17.5
EPSS0.00387
SSVC
4