Lucene search
+L

Atlassian Confluence 9.1.x < 9.2.24 / 9.3.x < 10.2.19 / 11.0.0 (CONFSERVER-104501)

🗓️ 21 Oct 2026 00:00:00Reported by TenableType 
nessus
 nessus
🔗 www.tenable.com👁 5 Views

Host-based policy bypass in Atlassian Confluence due to fast-uri Unicode hostname issues.

Related
Refs
Code
ReporterTitlePublishedViews
Family
ibm
IBM Security Bulletins
Security Bulletin: IBM InfoSphere Optim Archive Viewer is affected by a vulnerability in fast-uri (CVE-2026-13676)
23 Sep 202609:28
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Multiple vulnerabilities in IBM Aspera Faspex
20 Jul 202615:47
–ibm
ibm
IBM Security Bulletins
Security Bulletin:Multiple security vulnerabilities in IBM Process Automation Manager Open Edition Starter Kit for Banking
10 Aug 202609:53
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Vulnerability in fast-uri bundled with IBM Fusion, IBM Fusion HCI, and IBM Fusion Data Cataloging.
2 Oct 202616:55
–ibm
ibm
IBM Security Bulletins
Security Bulletin: MongoDB Enterprised Advanced affected by: Interpretation Conflict (CVE-2026-13676)
3 Sep 202619:07
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Platform Navigator and Automation Assets in IBM Cloud Pak for Integration are vulnerable to multiple vulnerabilitie
24 Jul 202615:43
–ibm
ibm
IBM Security Bulletins
Security Bulletin: There are vulnerabilities in jackson-databind-2.18.6.jar, protobufjs-8.3.0.tgz and fast-uri-3.1.2.tgz used by IBM Maximo Manage application in IBM Maximo Application Suite which are affected by multiple CVEs
3 Aug 202608:19
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Multiple Vulnerabilities in IBM watsonx Code Assistant On Prem
15 Sep 202615:47
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Multiple Vulnerabilities affect IBM Decision Optimization for Cloud Pak for Data.
3 Sep 202616:23
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM Bob Premium Package for i is affected by multiple vulnerabilities
7 Aug 202600:16
–ibm
Rows per page
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##

include('compat.inc');

if (description)
{
  script_id(368963);
  script_version("1.1");
  script_set_attribute(attribute:"plugin_modification_date", value:"2026/10/21");

  script_cve_id("CVE-2026-13676");

  script_name(english:"Atlassian Confluence 9.1.x < 9.2.24 / 9.3.x < 10.2.19 / 11.0.0 (CONFSERVER-104501)");

  script_set_attribute(attribute:"synopsis", value:
"The remote Atlassian Confluence host is missing a security update.");
  script_set_attribute(attribute:"description", value:
"The version of Atlassian Confluence Server running on the remote host is affected by a vulnerability as referenced in
the CONFSERVER-104501 advisory.

  - fast-uri versions 2.3.1 through 3.1.2 and 4.0.0 fail to canonicalize Unicode (IDN) hostnames for HTTP-
    family URLs. The IDN conversion path calls a helper that does not exist on the global URL constructor,
    silently leaving the host in its original Unicode form while normalize() and equal() still return values
    that differ from a WHATWG-compatible URL parser. Applications that use fast-uri to enforce host-based
    policy (denylists, loopback filtering, redirect validation, outbound proxy routing) before passing the
    same URL to Node's URL or fetch can be bypassed when the two implementations resolve the same input to
    different hosts. Patches: upgrade to fast-uri 3.1.3 for the 3.x line or 4.0.1 for the 4.x line.
    Workarounds: enforce host policy using the same URL parser used for the actual request, or reject non-
    ASCII hosts before policy checks. (CVE-2026-13676)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
  script_set_attribute(attribute:"see_also", value:"https://jira.atlassian.com/browse/CONFSERVER-104501");
  script_set_attribute(attribute:"solution", value:
"Upgrade to Atlassian Confluence version 9.2.24, 10.2.19, 11.0.0 or later.");
  script_set_attribute(attribute:"agent", value:"all");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-13676");

  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2026/06/29");
  script_set_attribute(attribute:"patch_publication_date", value:"2026/10/16");
  script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/21");

  script_set_attribute(attribute:"plugin_type", value:"combined");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:atlassian:confluence");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_set_attribute(attribute:"thorough_tests", value:"true");
  script_set_attribute(attribute:"enable_cgi_scanning", value:"true");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("confluence_detect.nasl", "confluence_nix_installed.nbin", "confluence_win_installed.nbin");
  script_require_keys("installed_sw/Atlassian Confluence");

  exit(0);
}

include('vdf.inc');

# @tvdl-content-verify-only
var vuln_data = {
  "metadata": {
    "spec_version": "1.0"
  },
  "checks": [
    {
      "product": {
        "name": "Atlassian Confluence",
        "type": "app"
      },
      "check_algorithm": "default",
      "constraints": [
        {
          "min_version": "9.1.0",
          "fixed_version": "9.2.24",
          "fixed_display": "9.2.24 / 10.2.19 / 11.0.0"
        },
        {
          "min_version": "9.3.1",
          "fixed_version": "10.2.19",
          "fixed_display": "10.2.19 / 11.0.0"
        }
      ]
    }
  ]
};

var vdf_result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_HOLE);
vdf::handle_check_and_report_errors(vdf_result:vdf_result);

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

21 Oct 2026 00:00Current
6.5Medium risk
Vulners AI Score6.5
CVSS 3.17.5
EPSS0.00692
SSVC
5