Lucene search
+L

Atlassian Confluence < 9.2.24 / 9.5.x < 10.2.17 / 11.0.0 (CONFSERVER-104473)

🗓️ 21 Oct 2026 00:00:00Reported by TenableType 
nessus
 nessus
🔗 www.tenable.com👁 5 Views

DoS in Atlassian Confluence via Bouncy Castle for Java OER parser recursion.

Related
Refs
Code
ReporterTitlePublishedViews
Family
ibm
IBM Security Bulletins
Security Bulletin: Security vulnerability is addressed in IBM Daeja ViewONE as part of iFix release in August 2026
27 Aug 202610:34
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Due to the use of Bouncy Castle for Java, IBM Sterling Control Center is vulnerable to Uncontrolled Recursion(CVE-2026-59645)
22 Sep 202610:03
–ibm
ibm
IBM Security Bulletins
Security Bulletin: There are vulnerabilities in IBM Maximo Manage application in IBM Maximo Application Suite
28 Aug 202605:59
–ibm
ibm
IBM Security Bulletins
Security Bulletin: There are vulnerabilities in IBM Maximo Manage application in IBM Maximo Application Suite
16 Sep 202606:03
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Uncontrolled resource consumption, cross-site scripting, and other vulnerabilities might affect IBM Storage Defender - Resiliency Service
29 Sep 202600:18
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM App Connect for Manufacturing is vulnerable to multiple vulnerabilities due to Bouncy Castle
16 Sep 202607:24
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM Sterling Global Availability Mailbox is affected by a vulnerability in bouncy castle 1.84
16 Sep 202612:47
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Multiple vulnerabilities in IBM Rational Developer for i
15 Sep 202613:46
–ibm
ibm
IBM Security Bulletins
Security Bulletin: IBM Watson Speech Services Cartridge is vulnerable to an Uncontrolled Recursion in Bouncy Castle for Java (CVE-2026-59645)
22 Oct 202620:12
–ibm
ibm
IBM Security Bulletins
Security Bulletin: Multiple vulnerabilities in IBM Tivoli Network Manager IP Edition
22 Sep 202607:04
–ibm
Rows per page
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##

include('compat.inc');

if (description)
{
  script_id(368972);
  script_version("1.2");
  script_set_attribute(attribute:"plugin_modification_date", value:"2026/10/26");

  script_cve_id("CVE-2026-59645");

  script_name(english:"Atlassian Confluence < 9.2.24 / 9.5.x < 10.2.17 / 11.0.0 (CONFSERVER-104473)");

  script_set_attribute(attribute:"synopsis", value:
"The remote Atlassian Confluence host is missing a security update.");
  script_set_attribute(attribute:"description", value:
"The version of Atlassian Confluence Server running on the remote host is affected by a vulnerability as referenced in
the CONFSERVER-104473 advisory.

  - In Bouncy Castle for Java before 1.85, OER parser recurses without depth limit on self-referential IEEE
    1609.2 schema. This issue also affects Bouncy Castle for Java LTS before 2.73.12, and Bouncy Castle for
    Java FIPS (BC-FJA) before bcutil-fips 2.0.7 (2.0.X series) and 2.1.7 (2.1.X series). (CVE-2026-59645)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
  script_set_attribute(attribute:"see_also", value:"https://jira.atlassian.com/browse/CONFSERVER-104473");
  script_set_attribute(attribute:"solution", value:
"Upgrade to Atlassian Confluence version 9.2.24, 10.2.17, 11.0.0 or later.");
  script_set_attribute(attribute:"agent", value:"all");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
  script_set_attribute(attribute:"cvss4_vector", value:"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N");
  script_set_attribute(attribute:"cvss4_supplemental", value:"CVSS:4.0/U:Amber");
  script_set_attribute(attribute:"cvss4_threat_vector", value:"CVSS:4.0/E:U");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-59645");

  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2026/08/03");
  script_set_attribute(attribute:"patch_publication_date", value:"2026/09/20");
  script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/21");

  script_set_attribute(attribute:"plugin_type", value:"combined");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:atlassian:confluence");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_set_attribute(attribute:"thorough_tests", value:"true");
  script_set_attribute(attribute:"enable_cgi_scanning", value:"true");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("confluence_detect.nasl", "confluence_nix_installed.nbin", "confluence_win_installed.nbin");
  script_require_keys("installed_sw/Atlassian Confluence");

  exit(0);
}

include('vdf.inc');

# @tvdl-content-verify-only
var vuln_data = {
  "metadata": {
    "spec_version": "1.0"
  },
  "checks": [
    {
      "product": {
        "name": "Atlassian Confluence",
        "type": "app"
      },
      "check_algorithm": "default",
      "constraints": [
        {
          "fixed_version": "9.2.24",
          "fixed_display": "9.2.24 / 10.2.17 / 11.0.0"
        },
        {
          "min_version": "9.5.4",
          "fixed_version": "10.2.17",
          "fixed_display": "10.2.17 / 11.0.0"
        }
      ]
    }
  ]
};

var vdf_result = vdf::check_and_report(vuln_data:vuln_data, severity:SECURITY_HOLE);
vdf::handle_check_and_report_errors(vdf_result:vdf_result);

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

26 Oct 2026 00:00Current
7.3High risk
Vulners AI Score7.3
CVSS 3.17.5
CVSS 48.7
EPSS0.00408
SSVC
5