Lucene search
+L

CKEditor 45.x < 47.7.4 / 48.x < 48.5.1 XSS

🗓️ 29 Oct 2026 00:00:00Reported by TenableType 
nessus
 nessus
🔗 www.tenable.com👁 4 Views

XSS in CKEditor via es-toolkit prototype pollution in style attribute values.

Related
Refs
Code
ReporterTitlePublishedViews
Family
circl
Circl
CVE-2026-116688
27 Oct 202619:41
–circl
cve
CVE
CVE-2026-116688
27 Oct 202619:36
–cve
cvelist
Cvelist
CVE-2026-116688 CKEditor: Cross-site scripting (XSS) in the engine package
27 Oct 202619:36
–cvelist
euvd
EUVD
EUVD-2026-111364
27 Oct 202619:36
–euvd
github
Github Security Blog
CKEditor: Cross-site scripting (XSS) in the engine package
27 Oct 202621:05
–github
mend
Mend
CVE-2026-116688
27 Oct 202619:36
–mend
nvd
NVD
CVE-2026-116688
27 Oct 202620:17
–nvd
osv_ghsa
osv_ghsa
GHSA-RH54-VFFM-5FVP CKEditor: Cross-site scripting (XSS) in the engine package
27 Oct 202621:05
–osv_ghsa
osv_ubuntu
osv_ubuntu
UBUNTU-CVE-2026-116688
27 Oct 202620:17
–osv_ubuntu
patchstack
Patchstack
npm: CKEditor: Cross-site scripting (XSS) in the engine package
27 Oct 202621:05
–patchstack
Rows per page
#%NASL_MIN_LEVEL 80900
##
# (C) Tenable, Inc.
##

include('compat.inc');

if (description)
{
  script_id(373617);
  script_version("1.2");
  script_set_attribute(attribute:"plugin_modification_date", value:"2026/10/30");

  script_cve_id("CVE-2026-116688");
  script_xref(name:"IAVA", value:"2026-A-1222");

  script_name(english:"CKEditor 45.x < 47.7.4 / 48.x < 48.5.1 XSS");

  script_set_attribute(attribute:"synopsis", value:
"The remote web server may be affected by a cross site scripting vulnerability.");
  script_set_attribute(attribute:"description", value:
"The version of CKEditor included on the remote web host is 45.x prior to 47.7.4, or 48.x prior to 48.5.1. It is,
therefore, affected by a cross-site scripting (XSS) vulnerability. The CKEditor 5 engine uses a vulnerable es-toolkit
version whose prototype-pollution behavior can be reached while CKEditor processes incoming style attribute values.
Crafted editor content can thereby cause unauthorized JavaScript execution in the browser.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version
number.");
  # https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-rh54-vffm-5fvp
  script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?2cbd9462");
  script_set_attribute(attribute:"see_also", value:"https://github.com/ckeditor/ckeditor5/releases/tag/v47.7.4");
  script_set_attribute(attribute:"see_also", value:"https://github.com/ckeditor/ckeditor5/releases/tag/v48.5.1");
  script_set_attribute(attribute:"solution", value:
"Upgrade to CKEditor 47.7.4 / 48.5.1 or later.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:N");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2026-116688");

  script_set_attribute(attribute:"vuln_publication_date", value:"2026/09/16");
  script_set_attribute(attribute:"patch_publication_date", value:"2026/09/16");
  script_set_attribute(attribute:"plugin_publication_date", value:"2026/10/29");

  script_set_attribute(attribute:"plugin_type", value:"remote");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:cksource:ckeditor");
  script_set_attribute(attribute:"stig_severity", value:"I");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses : XSS");

  script_copyright(english:"This script is Copyright (C) 2026 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("cksource_ckeditor_cdn_detect.nbin");
  script_require_keys("installed_sw/CKSource CKEditor");

  exit(0);
}

include('vcf.inc');

var app_info = vcf::combined_get_app_info(app:'CKSource CKEditor');

var constraints = [
  {'min_version':'45.0.0', 'fixed_version':'47.7.4'},
  {'min_version':'48.0.0', 'fixed_version':'48.5.1'}
];

vcf::check_version_and_report(
  app_info:app_info,
  constraints:constraints,
  severity:SECURITY_HOLE,
  flags:{xss:TRUE}
);

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

30 Oct 2026 00:00Current
5.7Medium risk
Vulners AI Score5.7
CVSS 3.18.1
EPSS0.00497
4