Amazon Linux 2 : filesystem (ALAS-2019-1175)

2019-03-15T00:00:00
ID AL2_ALAS-2019-1175.NASL
Type nessus
Reporter This script is Copyright (C) 2019 and is owned by Tenable, Inc. or an Affiliate thereof.
Modified 2021-05-02T00:00:00

Description

Images built for the Amazon Linux 2.0.20190218 release included system files with incorrect permissions applied.

Incorrect permissions were applied to files including :

/etc/fstab

/etc/localtime

/etc/image-id

/etc/sysconfig/i18n

/etc/sysconfig/clock

/etc/sysconfig/keyboard

/etc/sysctl.d/99-amazon.conf

/var/lib/rpm/Packages

All users should upgrade to this updated package which corrects permissions for these files if they are not already in the expected state. The latest Amazon Linux 2 AMIs, on-premises VM images, and Docker Hub listings already include these updates.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#
# The descriptive text and package checks in this plugin were
# extracted from Amazon Linux 2 Security Advisory ALAS-2019-1175.
#

include("compat.inc");

if (description)
{
  script_id(122861);
  script_version("1.1");
  script_cvs_date("Date: 2019/03/15 10:28:26");

  script_xref(name:"ALAS", value:"2019-1175");

  script_name(english:"Amazon Linux 2 : filesystem (ALAS-2019-1175)");
  script_summary(english:"Checks rpm output for the updated packages");

  script_set_attribute(
    attribute:"synopsis", 
    value:"The remote Amazon Linux 2 host is missing a security update."
  );
  script_set_attribute(
    attribute:"description", 
    value:
"Images built for the Amazon Linux 2.0.20190218 release included system
files with incorrect permissions applied.

Incorrect permissions were applied to files including :

/etc/fstab

/etc/localtime

/etc/image-id

/etc/sysconfig/i18n

/etc/sysconfig/clock

/etc/sysconfig/keyboard

/etc/sysctl.d/99-amazon.conf

/var/lib/rpm/Packages

All users should upgrade to this updated package which corrects
permissions for these files if they are not already in the expected
state. The latest Amazon Linux 2 AMIs, on-premises VM images, and
Docker Hub listings already include these updates."
  );
  script_set_attribute(
    attribute:"see_also",
    value:"https://alas.aws.amazon.com/AL2/ALAS-2019-1175.html"
  );
  script_set_attribute(
    attribute:"solution", 
    value:"Run 'yum update filesystem' to update your system."
  );
  script_set_attribute(attribute:"risk_factor", value:"High");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:amazon:linux:filesystem");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:amazon:linux:filesystem-content");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:amazon:linux:2");

  script_set_attribute(attribute:"vuln_publication_date", value:"2019/03/14");
  script_set_attribute(attribute:"patch_publication_date", value:"2019/03/14");
  script_set_attribute(attribute:"plugin_publication_date", value:"2019/03/15");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_copyright(english:"This script is Copyright (C) 2019 and is owned by Tenable, Inc. or an Affiliate thereof.");
  script_family(english:"Amazon Linux Local Security Checks");

  script_dependencies("ssh_get_info.nasl");
  script_require_keys("Host/local_checks_enabled", "Host/AmazonLinux/release", "Host/AmazonLinux/rpm-list");

  exit(0);
}


include("audit.inc");
include("global_settings.inc");
include("rpm.inc");


if (!get_kb_item("Host/local_checks_enabled")) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);

release = get_kb_item("Host/AmazonLinux/release");
if (isnull(release) || !strlen(release)) audit(AUDIT_OS_NOT, "Amazon Linux");
os_ver = pregmatch(pattern: "^AL(A|\d)", string:release);
if (isnull(os_ver)) audit(AUDIT_UNKNOWN_APP_VER, "Amazon Linux");
os_ver = os_ver[1];
if (os_ver != "2")
{
  if (os_ver == 'A') os_ver = 'AMI';
  audit(AUDIT_OS_NOT, "Amazon Linux 2", "Amazon Linux " + os_ver);
}

if (!get_kb_item("Host/AmazonLinux/rpm-list")) audit(AUDIT_PACKAGE_LIST_MISSING);


flag = 0;
if (rpm_check(release:"AL2", reference:"filesystem-3.2-25.amzn2.0.1")) flag++;
if (rpm_check(release:"AL2", reference:"filesystem-content-3.2-25.amzn2.0.1")) flag++;

if (flag)
{
  if (report_verbosity > 0) security_hole(port:0, extra:rpm_report_get());
  else security_hole(0);
  exit(0);
}
else
{
  tested = pkg_tests_get();
  if (tested) audit(AUDIT_PACKAGE_NOT_AFFECTED, tested);
  else audit(AUDIT_PACKAGE_NOT_INSTALLED, "filesystem / filesystem-content");
}