MediaWiki < 1.19.23 / 1.22.15 / 1.23.8 / 1.24.1 Multiple Vulnerabilities

2014-12-29T00:00:00
ID 8611.PRM
Type nessus
Reporter Tenable
Modified 2019-03-06T00:00:00

Description

In versions older than 1.24.1, 1.22.15 or 1.19.23 or 1.23.8, MediaWiki contains a flaw in API handling which allows an attacker to bypass authentication. This issue occurs when a website includes an allowed domain as part of its name in '$wgCrossSiteAJAXdomains' in API calls. An attacker can exploit this issue to bypass CORS restrictions. Older versions of MediaWiki are also prone to a cross-site scripting vulnerability because 'thumb.php' script fails to properly sanitize user-supplied input when handling wikitext messages before returning it to the users.

                                        
                                            Binary data 8611.prm