Damn Vulnerable Node Application: DVNA

2015-12-21T17:51:44
ID N0WHERE:76023
Type n0where
Reporter N0where
Modified 2015-12-21T17:51:44

Description

Damn Vulnerable Node Application (DVNA) is a node.js web application that is damn vulnerable. Its main goal is to be an aid for security professionals to test their skills and tools in a legal environment, help web developers better understand the processes of securing web applications and to aid both students & teachers to learn about web application security in a controlled class room environment or to serve as a cyber range for capture the flag events.

The aim of DVNA is to practice some of the most common web vulnerability , with various difficultly levels , with a simple straightforward interface. Please note, there are both documented and undocumented vulnerability with this software. This is intentional. You are encouraged to try and discover as many issues as possible.

Install:

git clone https://github.com/quantumfoam/DVNA
cd DVNA

If you are using a Debian based Linux distribution, you will need to install the following packages (or their equivalent):

apt-get -y install apache2 mysql-server php5 php5-mysql php5-gd

Default Credentials:

Default username = admin
Default password = password

Damn Vulnerable Node Application is damn vulnerable! Do not upload it to your hosting provider’s public html folder or any Internet facing servers, as they will be compromised. It is recommend using a virtual machine (such as VirtualBox or VMware), which is set to NAT networking mode. Inside a guest machine, you can downloading and install XAMPP for the web server and database.

Source && Download

Damn Vulnerable Node Application: DVNA download