Security and Quality Rollup updates for .NET Framework 3.5, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, and 4.7.2 for Windows 7 SP1 and Windows Server 2008 R2 SP1 (KB 4471987)

2018-12-07T17:26:11
ID KB4471987
Type mskb
Reporter Microsoft
Modified 2018-12-11T17:56:40

Description

<html><body><p>Resolves a remote code execution vulnerability that exists when Microsoft .NET Framework does not validate input correctly. This security update addresses the vulnerability by correcting how .NET Framework validates input.</p><h2></h2><div class="alert-band"><div class="alert alert-info" role="alert"><p class="alert-title">Applies to:</p><div class="row"><div class="col-xs-24"><p>Microsoft .NET Framework 3.5.1, Microsoft .NET Framework 4.5.2, Microsoft .NET Framework 4.6, Microsoft .NET Framework 4.6.1, Microsoft .NET Framework 4.6.2, Microsoft .NET Framework 4.7, Microsoft .NET Framework 4.7.1, Microsoft .NET Framework 4.7.2</p></div></div></div></div><h2>Summary</h2><p><span><span><span><span>This security update resolves a vulnerability in Microsoft .NET Framework that could allow remote code execution when Microsoft .NET Framework doesn't validate input correctly. An attacker who successfully exploits this vulnerability could take control of an affected system. The attacker could then install programs; view, change, or delete data; or create new accounts that use full user rights. Users whose accounts are configured to have fewer user rights on the system could be less affected than users who aregranted administrative user rights.</span></span></span></span></p><p><span><span><span><span>To exploit the vulnerability, an attacker has to pass specific input to an application that uses susceptible .NET Framework methods.</span></span></span></span></p><p><span><span><span><span>This security update addresses the vulnerability by correcting how .NET Framework validates input.</span></span></span></span></p><p>To learn more about this vulnerability, see <a data-content-id="" data-content-type="" href="https://portal.msrc.microsoft.com/security-guidance/advisory/CVE-2018-8540" id="kb-link-2" managed-link="" target="_blank">Microsoft Common Vulnerabilities and Exposures CVE-2018-8540</a>.</p><p><strong><span class="text-base">Important</span></strong></p><ul><li>All updates for .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, and 4.7.2 require that the d3dcompiler_47.dll update is installed. We recommend that you install the included d3dcompiler_47.dll update before you apply this update. For more information about the d3dcompiler_47.dll, see <a data-content-id="" data-content-type="" href="https://support.microsoft.com/en-us/help/4019990" managed-link="" target="_blank">KB 4019990</a>.</li><li>If you install a language pack after you install this update, you must reinstall this update. Therefore, we recommend that you install any language packs that you need before you install this update. For more information, see <a bookmark-id="" data-content-id="" data-content-type="" href="https://technet.microsoft.com/en-us/library/hh825699" managed-link="" target="_blank">Add language packs to Windows</a>.</li></ul><h2>Additional information about this security update</h2><div><span>The following articles contain additional information about this security update as it relates to individual product versions.</span></div><div> </div><ul><li><span><a data-content-id="" data-content-type="" href="https://support.microsoft.com/help/4470641" managed-link="" target="_blank">4470641</a> Description of the Security and Quality Rollup for .NET Framework 3.5 for Windows 7 SP1 and Server 2008 R2 SP1 (KB 4470641)</span></li><li><a data-content-id="" data-content-type="" href="https://support.microsoft.com/help/4470637" managed-link="" target="_blank">4470637</a> Description of the Security and Quality Rollup for .NET Framework 4.5.2 for Windows 7 SP1, Server 2008 R2 SP1, and Server 2008 SP2 (KB 4470637)</li><li><a data-content-id="" data-content-type="" href="https://support.microsoft.com/help/4470640" managed-link="" target="_blank">4470640</a> Description of the Security and Quality Rollup for .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, and 4.7.2 for Windows 7 SP1 and Server 2008 R2 SP1 and for .NET Framework 4.6 for Server 2008 SP2 (KB 4470640)</li></ul><h2>How to obtain help and support for this security update</h2><ul><li><span>Help for installing updates: <a bookmark-id="" data-content-id="" data-content-type="" href="https://support.microsoft.com/en-us/help/12373/windows-update-faq" managed-link="" target="_blank">Windows Update FAQ</a></span></li><li>Protect yourself online and at home: <a href="https://support.microsoft.com/hub/4099151/windows-security-help" managed-link="" target="_blank">Windows Security support</a></li><li>Local support according to your country: <a bookmark-id="" data-content-id="" data-content-type="" href="http://support.microsoft.com" managed-link="" target="_blank">International Support</a></li></ul></body></html>