Security Only updates for .NET Framework 3.5, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 and 4.7.2 for Windows 8.1 and Server 2012 R2 (KB 4457916)

2018-10-11T12:25:42
ID KB4457916
Type mskb
Reporter Microsoft
Modified 2018-10-11T12:25:42

Description

<html><body><p>Resolves a vulnerability in Microsoft .NET Framework that could allow remote code execution when .NET Framework processes untrusted input.</p><h2></h2><p>This also applies to:</p><ul><li>Microsoft .NET Framework 3.5</li></ul><h2>Summary</h2><div class="kb-summary-section section"><p><span><span><span>This security update resolves a vulnerability in Microsoft .NET Framework that could allow remote code execution when .NET Framework processes untrusted input. An attacker who successfully exploits this vulnerability in software by using .NET Framework could take control of an affected system. An attacker could then install programs; view, change, or delete data; or create new accounts that have full user rights. Users whose accounts are configured to have fewer user rights on the system could be less affected than users who operate with administrative user rights.</span></span></span></p><p><span><span><span>To exploit the vulnerability, an attacker would first have to convince the user to open a malicious document or application.</span></span></span></p><p><span><span><span>This security update addresses the vulnerability by correcting how .NET Framework validates untrusted input.</span></span></span></p><p><span><span><span>To learn more about this vulnerability, see <a href="https://portal.msrc.microsoft.com/security-guidance/advisory/CVE-2018-8421"><span><span><span>Microsoft Common Vulnerabilities and Exposures CVE-2018-8421</span></span></span></a>.</span></span></span></p></div><h2></h2><p><strong><span class="text-base">Important</span></strong></p><ul><li><span><span><span> <span><span><span>All updates for Windows 8.1, Windows RT 8.1 and Windows Server 2012 R2 require update <a data-content-id="" data-content-type="" href="https://support.microsoft.com/en-us/help/2919355" target="">KB 2919355</a> to be installed. We recommend that you install update <a data-content-id="" data-content-type="" href="https://support.microsoft.com/en-us/help/2919355" target="">KB 2919355</a> on your Windows 8.1-based, Windows RT 8.1-based or Windows Server 2012 R2-based computer so that you receive updates in the future</span></span></span></span></span></span>.</li><li>If you install a language pack after you install this update, you must reinstall this update. Therefore, we recommend that you install any language packs that you need before you install this update. For more information, see <a bookmark-id="" data-content-id="" data-content-type="" href="https://technet.microsoft.com/en-us/library/hh825699" managed-link="" target="_blank">Add language packs to Windows</a>.</li></ul><h2>Known issues</h2><p>After the <a href="https://blogs.msdn.microsoft.com/dotnet/2018/09/11/net-framework-september-2018-security-and-quality-rollup/" managed-link="" target="_blank"><span><span><span><span>September 2018 .NET Framework security update</span></span></span></span></a> is applied to resolve <a href="https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-8421" managed-link="" target="_blank"><span><span><span><span>CVE-2018-8421</span></span></span></span></a> (.NET Framework remote code execution vulnerability), SharePoint out-of-the-box workflows stop working.</p><p>For more information about this known issue, see the following article in the Microsoft Knowledge Base:</p><p class="indent-1"><a href="https://support.microsoft.com/en-us/help/4465015" managed-link="" target="_blank"><span><span><span><span>4465015</span></span></span></span></a> SharePoint Workflows stop working after you install .NET security updates for CVE-2018-8421</p><h2>Additional information about this security update</h2><div><span>The following articles contain additional information about this security update as it relates to individual product versions.</span></div><div> </div><ul><li><span><a href="https://support.microsoft.com/help/4457056" managed-link="">4457056</a> Description of the Security Only update for .NET Framework 3.5 for Windows 8.1 and Server 2012 R2 (KB 4457056)</span></li><li><a href="https://support.microsoft.com/help/4457028" managed-link="">4457028</a> Description of the Security Only update for .NET Framework 4.5.2 for Windows 8.1 and Server 2012 R2 (KB 4457028)</li><li><a href="https://support.microsoft.com/help/4457026" managed-link="">4457026</a> Description of the Security Only update for .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 and 4.7.2 for Windows 8.1 and Server 2012 R2 (KB 4457026)</li></ul><h2>How to obtain help and support for this security update</h2><ul><li><span>Help for installing updates: <a bookmark-id="" data-content-id="" data-content-type="" href="https://support.microsoft.com/en-us/help/12373/windows-update-faq" managed-link="" target="_blank">Windows Update FAQ</a></span></li><li><span>Help for protecting your Windows-based products and services from viruses and malware: </span><a bookmark-id="" data-content-id="" data-content-type="" href="https://support.microsoft.com/contactus/cu_sc_virsec_master" managed-link="" target="_blank">Microsoft Secure</a></li><li><span>Local support according to your country: <a bookmark-id="" data-content-id="" data-content-type="" href="http://support.microsoft.com" managed-link="" target="_blank">International Support</a></span></li></ul></body></html>